Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-2826

Unable to save a freestyle job or a pipeline

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Labels:
      None
    • Environment:
      Jenkins 1.266, Running on Debian Buster, many plugins, Safari or Internet Explorer
    • Similar Issues:

      Description

      I created a simple freestyle job. Named it test and was taken to the job configuration page. This was broken as shown below - there are items to the right (disable job etc) and the Save and Apply buttons no longer work. Pressing the buttons has no effect. I have tried debugging the Javascript and have installed the Charles network monitor. It looks like the POST request is never sent (but I could be mistaken). This also happens for any job that I open (except for multitask pipelines, which I am able to change and save). I have attached the config.xml for this job.

      I have not seen any other report of a similar issue so it could be my environment. I am reluctant to delete my Jenkins installation and start from scratch since I have many jobs. I suspect I have a bad plugin, but again I wouldn't know which one to disable.

      I am unable to modify jobs other than hand-editing the xml file, which is a major issue for me, but since no-one else has reported a similar problem, it can't be an issue for everyone.

      I very rarely modify jobs so I don't know when this problem started happening

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          This is the Jenkins project infrastructure issue tracker.

          Please see https://www.jenkins.io/participate/report-issue/


          I have not seen any other report of a similar issue so it could be my environment. I am reluctant to delete my Jenkins installation and start from scratch since I have many jobs. I suspect I have a bad plugin, but again I wouldn't know which one to disable.

          Almost certainly related to https://www.jenkins.io/blog/2020/11/10/major-changes-in-weekly-releases/#configuration-ui-tables-to-divs

          See also the reports at https://issues.jenkins.io/issues/?jql=labels%20%3D%20tables-to-divs-regression and the changelog feedback on https://www.jenkins.io/changelog/


          Also, before you resubmit this, please review your submission content. Jenkins 1.266 was released in 2008 and it was called Hudson then.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            derekk19 Derek Knight
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: