Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33055

Misleading helper text on "Update a Field"


    • Icon: Improvement Improvement
    • Resolution: Fixed
    • Icon: Minor Minor
    • jira-ext-plugin
    • None

      I tried multiple times to get a custom field to update while following the helper text:

      "The name of the field. For custom fields this will have something like customField_12349"

      However, it turns out (or it would seem), that you have to have the field name all lowercase... (that is the only way I got it to work)... If I capitalized the "F" in Field, I'd get an error:

      Filed 'customField_XXXXX' does not exist or read-only

      As soon as I lowercased it all, it worked. The instructions should either specify this, OR, if it is true that the Jira REST API is always lowercase, then the value passed by the user should be lowercased before sending it to Jira.

            dalvizu Dan Alvizu
            billapepper Nikk Folts
            0 Vote for this issue
            3 Start watching this issue