Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44021

Issue with HP Application Automation Tools plugin

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I am trying to utilize HP Application Automation Tools plugin to connect to ALM QC server from Jenkins to execute testscripts created as VAPI-XP-TEST. But I am not seeing "Running Tests Sets from ALM" at options and when I am trying with Running Performance Tests using HP Performance Center option it doesnt work. 

      Also when I am using this plugin some of my other builds failing with below error. Someone could help me to fix these issues?

      I am mainly looking for pipeline script options.
      java.lang.NullPointerException
      at com.hp.application.automation.tools.octane.events.SCMListenerImpl.onChangeLogParsed(SCMListenerImpl.java:84)

        Attachments

          Activity

          eldojoseph1234 Eldo Joseph created issue -
          eldojoseph1234 Eldo Joseph made changes -
          Field Original Value New Value
          Rank Ranked higher
          yafim_kazak Yafim Kazak made changes -
          Assignee Ofir Shaked [ ofirshaked ] Oren Pelzman [ orenpelzman ]
          debadatta3 debadatta mishra made changes -
          Assignee Oren Pelzman [ orenpelzman ] debadatta mishra [ debadatta3 ]
          yafim_kazak Yafim Kazak made changes -
          Labels PerformanceCenter
          yafim_kazak Yafim Kazak made changes -
          Assignee debadatta mishra [ debadatta3 ] Oren Pelzman [ orenpelzman ]
          yafim_kazak Yafim Kazak added a comment -

          Hi,

          please separate each issue into different tickets.

          Please also state the following in environment so that we can better identify the issue:

          1. Jenkins version and plugin version
          2. Master/Slave configuration and OS version
          3. HPE PC version

           

          Thanks,

          Yafim.

          eldojoseph1234 Eldo Joseph added a comment -

          Hi Yafim,

          Please find the details.

          Jenkins version and plugin version

                        CloudBees Jenkins Enterprise 2.46.2.1

          Master/Slave configuration and OS version

                          Linux x86_64 master/slave

          HPE PC version

              12.53

          eldojoseph1234 Eldo Joseph added a comment -

          Yafim,

          Which issue you will be working on this ticket?

          yafim_kazak Yafim Kazak added a comment -

          Whatever you prefer 

          eldojoseph1234 Eldo Joseph added a comment -

          I prefer to go with below issue   It will be great if you can fix the issue soon. We are waiting to enable QC test execution.

          I am trying to utilize HP Application Automation Tools plugin to connect to ALM QC server from Jenkins to execute testscripts created as VAPI-XP-TEST. But I am not seeing "Running Tests Sets from ALM" at options and when I am trying with Running Performance Tests using HP Performance Center option it doesnt work. 

          yafim_kazak Yafim Kazak made changes -
          Link This issue duplicates JENKINS-42580 [ JENKINS-42580 ]
          yafim_kazak Yafim Kazak made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Closed [ 6 ]
          yafim_kazak Yafim Kazak made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          yafim_kazak Yafim Kazak made changes -
          Link This issue is related to JENKINS-42580 [ JENKINS-42580 ]
          yafim_kazak Yafim Kazak made changes -
          Comment [ I'm guessing you're using the Jenkins plugin v5.1?

          We've sorted it out in our beta (will be part of our LTS release in August 2017) - more details in the following ticket:

          https://issues.jenkins-ci.org/browse/JENKINS-42580

            ]
          yafim_kazak Yafim Kazak made changes -
          Link This issue is related to JENKINS-42580 [ JENKINS-42580 ]
          yafim_kazak Yafim Kazak made changes -
          Link This issue duplicates JENKINS-42580 [ JENKINS-42580 ]
          yafim_kazak Yafim Kazak added a comment -

          Please add the plugin version you're using.

          eldojoseph1234 Eldo Joseph added a comment -

          HP Application Automation Tools 5.1

          eldojoseph1234 Eldo Joseph added a comment -

          We made some configuration changes at server and we were able to move forward with windows machine. But we are receiving below error. Is it required plugin upgrade?

           
          The OTA version is not compatible with the current version of the Application Lifecycle Management server:
          http://higalmqcenter/qcbin/wcomsrv.dll
          .
          OTA version: 11.52, OTA build number: 514. Server version: 12.53, server build number: 1683.
          Error: Cannot Login to QC: Authorization failed.
          Build step 'Execute HP functional tests from HP ALM' changed build result to FAILURE

          orenpelzman Oren Pelzman made changes -
          Assignee Oren Pelzman [ orenpelzman ] Yafim Kazak [ yafim_kazak ]
          yafim_kazak Yafim Kazak made changes -
          Assignee Yafim Kazak [ yafim_kazak ] xiwen zhao [ xiwenhpe ]
          yafim_kazak Yafim Kazak added a comment -

          xiwen zhao please review.

          xiwenhpe xiwen zhao added a comment -

          Hi Joseph,

          Could you please try to run test without Jenkins? Launch UFT on your windows slave, run a test on ALM see if it gets same error.

          Thanks

          xiwenhpe xiwen zhao added a comment -

          Confirmed with ALM team, OTA must match server version.

          Open ALM on your slave machine, click "Tools", click "HP ALM Client Registration", click "Register HP ALM"

          It should solve your problem.

          yafim_kazak Yafim Kazak added a comment -

          Hi Eldo Joseph,
          please confirm if this resolves this issue and close the ticket if it does.
          Thanks.

          eldojoseph1234 Eldo Joseph added a comment -

          Yafim Kazak, sorry issue is still there. We tried after doing Register process. We are getting a different error now.

           
          HpToolsLauncher.exe -paramfile props26052017111301608.txt
          "Started..."
          Timeout is set to: 60
          Run mode is set to: RUN_PLANNED_HOST
          ============================================================================
          Starting test set execution
          Test set name: SmokeTestSuite, Test set id: 2551
          Could not create scheduler, please verify ALM client installation on run machine by downloading and in installing the add-in form:
          http://higalmqcenter/qcbin//TDConnectivity_index.html

           

          We tried installing TDConnectivity_index.html but not working.

          yafim_kazak Yafim Kazak made changes -
          Labels PerformanceCenter ALM UFT
          xiwenhpe xiwen zhao added a comment -

          Hi,

          this is a duplicated issue (JENKINS-19374)

          We are not able to reproduce the problem locally, there is not much we can do at this stage.

          If you need to solve this issue please contact UFT support or ALM support to open a ticket, professional support team will follow up this issue. In this way your problem will have monitoring and tracking, in addition the case will be raised to higher level if it can not be solved in a short time. In another word it is guaranteed to be fixed by raising a support ticket.

          Meanwhile I will mark this issue as closed.

          xiwenhpe xiwen zhao made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Reopened [ 4 ] Resolved [ 5 ]
          yafim_kazak Yafim Kazak made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          yafim_kazak Yafim Kazak made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Reopened [ 4 ] Closed [ 6 ]
          yafim_kazak Yafim Kazak made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          yafim_kazak Yafim Kazak made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Reopened [ 4 ] Closed [ 6 ]
          ram_sarisa ram sarisa made changes -
          Status Closed [ 6 ] In Review [ 10005 ]
          ram_sarisa ram sarisa made changes -
          Status In Review [ 10005 ] In Progress [ 3 ]
          roy_lu Roy Lu made changes -
          Priority Blocker [ 1 ] Minor [ 4 ]
          rpinap rodney pina made changes -
          Priority Minor [ 4 ] Critical [ 2 ]
          yafim_kazak Yafim Kazak made changes -
          Assignee xiwen zhao [ xiwenhpe ] Evan Chen [ evanchen ]
          gront Daniel Gront made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status In Progress [ 3 ] Open [ 1 ]
          gront Daniel Gront made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Closed [ 6 ]

            People

            Assignee:
            evanchen Evan Chen
            Reporter:
            eldojoseph1234 Eldo Joseph
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: