Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-46848

Username with backslash causes 404 at /user/username

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Duplicate
    • core
    • Jenkins: 2.78
      OS: Windows Server 2016 Datacenter 1607
      Plugins: None
      Browser: Chrome 60

    Description

      If a create a user with a backslash in the name, for example 'thisisau\sername', clicking the name in the top-right of the header takes me to a 404 page, trying to get to https://server:8080/user/thisisau/sername/.

      If I replace the '/' in the URL username with '%5C' (encoded backslash) it successfully loads the user page.

      Attachments

        1. jenkins-bug-1.png
          jenkins-bug-1.png
          8 kB
        2. jenkins-bug-2.png
          jenkins-bug-2.png
          24 kB
        3. screenshot-1.png
          screenshot-1.png
          438 kB
        4. screenshot-2.png
          screenshot-2.png
          170 kB

        Issue Links

          Activity

            jamesevickery James Vickery created issue -
            danielbeck Daniel Beck made changes -
            Field Original Value New Value
            Labels windows
            danielbeck Daniel Beck added a comment -

            On OS X both forward slash and back slash work in user IDs, so this is probably specific to Windows.

            teilo Are you able to reproduce this issue?

            danielbeck Daniel Beck added a comment - On OS X both forward slash and back slash work in user IDs, so this is probably specific to Windows. teilo Are you able to reproduce this issue?
            jamesevickery James Vickery made changes -
            Environment Jenkins: 1.625.3
            OS: Windows Server 2016 Datacenter 1607
            Plugins: None
            Browser: Chrome 60
            Jenkins: 2.78
            OS: Windows Server 2016 Datacenter 1607
            Plugins: None
            Browser: Chrome 60
            jamesevickery James Vickery added a comment -

            Sorry, got the version number wrong - I've just updated it. The Jenkins installer was downloaded earlier today so I assume it's the latest stable version. Thanks

            jamesevickery James Vickery added a comment - Sorry, got the version number wrong - I've just updated it. The Jenkins installer was downloaded earlier today so I assume it's the latest stable version. Thanks
            teilo James Nord added a comment -

            I'm sure this is a dupe of something... or something changed (the original bug and got replaced by this)

            teilo James Nord added a comment - I'm sure this is a dupe of something... or something changed (the original bug and got replaced by this)
            jamesevickery James Vickery added a comment -

            teilo I haven't raised this before, I only made an account to raise this issue. I briefly checked for duplicates but couldn't find anything similar

            jamesevickery James Vickery added a comment - teilo I haven't raised this before, I only made an account to raise this issue. I briefly checked for duplicates but couldn't find anything similar
            teilo James Nord made changes -
            Attachment screenshot-1.png [ 40529 ]
            teilo James Nord made changes -
            Attachment screenshot-2.png [ 40530 ]
            teilo James Nord added a comment - - edited

            danielbeck reproduced on 2.73.3 (java -jar jenkins.war --httpListenAddress=127.0.0.1)


            teilo James Nord added a comment - - edited danielbeck reproduced on 2.73.3 (java -jar jenkins.war --httpListenAddress=127.0.0.1)
            teilo James Nord added a comment -

            The dupe is JENKINS-33304 - but that has now been closed and so was probably an incomplete fix.

            teilo James Nord added a comment - The dupe is JENKINS-33304 - but that has now been closed and so was probably an incomplete fix.
            teilo James Nord added a comment -

            OK so likely a dupe of JENKINS-32623 which daniel has fixed and should be in the next LTS.

            teilo James Nord added a comment - OK so likely a dupe of JENKINS-32623 which daniel has fixed and should be in the next LTS.
            teilo James Nord added a comment -

            verified this is indeed fixed using jenkins 2.92

            teilo James Nord added a comment - verified this is indeed fixed using jenkins 2.92
            teilo James Nord made changes -
            Link This issue duplicates JENKINS-32623 [ JENKINS-32623 ]
            teilo James Nord made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            teilo James Nord made changes -
            Status Resolved [ 5 ] In Review [ 10005 ]
            teilo James Nord made changes -
            Resolution Fixed [ 1 ] Duplicate [ 3 ]
            Status In Review [ 10005 ] Resolved [ 5 ]
            teilo James Nord made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

            People

              Unassigned Unassigned
              jamesevickery James Vickery
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: