Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-62133

Configure screen: Resource Root URL validation error - 404 instance-identity

    XMLWordPrintable

Details

    • Jenkins 2.235

    Description

      It seems that something is wrong in how this validation is performed.

      This is reproduceable running locally with:

      Attachments

        Issue Links

          Activity

            build_admiral Fred Vogt created issue -
            build_admiral Fred Vogt made changes -
            Field Original Value New Value
            Environment Jenkins 2.234, AWS ec2 instance running jenkins container.

            Jenkins URL: https://jenkins-backend.dev.cicdenv.com/
            Resoure Root URL: https://builds-backend.dev.cicdenv.com/

            Both DNS names go to an AWS ALB with host routing rules.

            jenkins:
              crumbIssuer:
                standard:
                  excludeClientIPFromCrumb: true

            JenkinsLocationConfiguration.get().url = ...
            ResourceDomainConfiguration.get().url = ...
            Jenkins 2.234 local or AWS
            build_admiral Fred Vogt added a comment - - edited

            Jenkins 2.234, AWS ec2 instance running jenkins container.

            Jenkins URL: https://jenkins-backend.dev.cicdenv.com/
            Resoure Root URL: https://builds-backend.dev.cicdenv.com/

            Both DNS names go to an AWS ALB with host routing rules.

            jenkins:
            crumbIssuer:
            standard:
            excludeClientIPFromCrumb: true

            The server/resource root URLs are set in groovy hooky scripts:
            JenkinsLocationConfiguration.get().url = ...
            ResourceDomainConfiguration.get().url = ...

            I haven't used a separate resource root url before.
            https://github.com/jenkinsci/jenkins/pull/4239

            I put a custom logo override into userContent and it is working which leads me to believe the resource root url setting is working, however the check against /instance-identity/ is failing in the configure page.

            I don't think this problem is new in version 2.234.

            build_admiral Fred Vogt added a comment - - edited Jenkins 2.234, AWS ec2 instance running jenkins container. Jenkins URL: https://jenkins-backend.dev.cicdenv.com/ Resoure Root URL: https://builds-backend.dev.cicdenv.com/ Both DNS names go to an AWS ALB with host routing rules. jenkins: crumbIssuer: standard: excludeClientIPFromCrumb: true The server/resource root URLs are set in groovy hooky scripts: JenkinsLocationConfiguration.get().url = ... ResourceDomainConfiguration.get().url = ... I haven't used a separate resource root url before. https://github.com/jenkinsci/jenkins/pull/4239 I put a custom logo override into userContent and it is working which leads me to believe the resource root url setting is working, however the check against /instance-identity/ is failing in the configure page. I don't think this problem is new in version 2.234.
            build_admiral Fred Vogt made changes -
            Summary Resource Root URL shows 404 validation error in configure screen Configure screen Resource Root URL validation error - 404 instance-identity
            build_admiral Fred Vogt made changes -
            Attachment Screen Shot 2020-04-30 at 15.06.40.png [ 51130 ]
            build_admiral Fred Vogt made changes -
            Attachment Screen Shot 2020-04-30 at 15.09.29.png [ 51128 ]
            build_admiral Fred Vogt made changes -
            Attachment Screen Shot 2020-04-30 at 15.08.29.png [ 51129 ]
            build_admiral Fred Vogt made changes -
            Attachment sample-server-url-2020-04-30.png [ 51131 ]
            build_admiral Fred Vogt made changes -
            build_admiral Fred Vogt made changes -
            Attachment sample-resource-root-url-reachale-2020-04-30.png [ 51133 ]
            build_admiral Fred Vogt made changes -
            Attachment sample-resource-root-url-reachale-2020-04-30.png [ 51133 ]
            build_admiral Fred Vogt made changes -
            build_admiral Fred Vogt made changes -
            Summary Configure screen Resource Root URL validation error - 404 instance-identity Configure screen: Resource Root URL validation error - 404 instance-identity
            danielbeck Daniel Beck added a comment -

            I am able to reproduce it with a 2.234 docker image. Weird, I specifically tested this.

            danielbeck Daniel Beck added a comment - I am able to reproduce it with a 2.234 docker image. Weird, I specifically tested this.
            danielbeck Daniel Beck made changes -
            Assignee Daniel Beck [ danielbeck ]
            danielbeck Daniel Beck added a comment -

            This worked as intended in 2.200.

            danielbeck Daniel Beck added a comment - This worked as intended in 2.200.
            danielbeck Daniel Beck made changes -
            Labels regression
            danielbeck Daniel Beck added a comment -

            This broke in 2.205 because of the Winstone update that changed the 404 error message format.

            The form validation expects a message to occur in a 404 error response and it seems it no longer matches exactly. That's the only difference between the "404 Not Found" error, and "This is a previously set up resource domain".

            danielbeck Daniel Beck added a comment - This broke in 2.205 because of the Winstone update that changed the 404 error message format. The form validation expects a message to occur in a 404 error response and it seems it no longer matches exactly. That's the only difference between the "404 Not Found" error, and "This is a previously set up resource domain".
            danielbeck Daniel Beck made changes -
            Labels regression regression winstone
            danielbeck Daniel Beck added a comment -

            Upstream regression is https://github.com/eclipse/jetty.project/issues/4154 (and rejected).

            danielbeck Daniel Beck added a comment - Upstream regression is https://github.com/eclipse/jetty.project/issues/4154 (and rejected).
            danielbeck Daniel Beck made changes -
            Labels regression winstone lts-candidate regression winstone
            danielbeck Daniel Beck made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            danielbeck Daniel Beck made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            danielbeck Daniel Beck made changes -
            Remote Link This issue links to "PR 4701 (Web Link)" [ 24887 ]
            danielbeck Daniel Beck added a comment -

            Just to confirm,

            I put a custom logo override into userContent and it is working which leads me to believe the resource root url setting is working, however the check against /instance-identity/ is failing in the configure page.

            This is correct; it's just the form validation that's affected, as it can no longer distinguish a 404 response from a resource root URL from just any other 404 response.

            danielbeck Daniel Beck added a comment - Just to confirm, I put a custom logo override into userContent and it is working which leads me to believe the resource root url setting is working, however the check against /instance-identity/ is failing in the configure page. This is correct; it's just the form validation that's affected, as it can no longer distinguish a 404 response from a resource root URL from just any other 404 response.
            build_admiral Fred Vogt added a comment -

            danielbeck - thanks for responding and diagnosing so quickly.

            build_admiral Fred Vogt added a comment - danielbeck - thanks for responding and diagnosing so quickly.
            danielbeck Daniel Beck made changes -
            Released As Jenkins 2.235
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Closed [ 6 ]
            olivergondza Oliver Gond┼ża made changes -
            Labels lts-candidate regression winstone 2.222.4-fixed regression winstone

            People

              danielbeck Daniel Beck
              build_admiral Fred Vogt
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: