Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-65585

incompatability between FormSubmission and HTMLUnit post Jenkins 2.289

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Several plugins have failing tests when using new versions of core (e.g. `mvn test -Djenkins.version=2.289`) and they seem to follow a simiular pattern

      calling HTMLUnit's `click` to submit a form is resulting in Jenkins erroring with something like

        15.170 [id=94]        WARNING o.e.j.s.h.ContextHandler$Context#log: Error while serving http://localhost:64686/jenkins/job/testFolder/support/generateAndDownload
      net.sf.json.JSONException: A JSONObject text must begin with '{' at character 1 of init
              at net.sf.json.util.JSONTokener.syntaxError(JSONTokener.java:499)
              at net.sf.json.JSONObject._fromJSONTokener(JSONObject.java:919)
      ...
      

      which subsequently causes the test to fail.

      On the surface this appears to be an incompatability between HTMLUnit and Jenkins bumping to the latest HTMLUnit seemed to make no difference.

      So far observed the issue in

      • support-core
      • ldap
      • ssh-slaves
      • pipeline-input-step

        Attachments

          Issue Links

            Activity

            teilo James Nord created issue -
            teilo James Nord made changes -
            Field Original Value New Value
            Description Several plugins have failing tests when using new versions of core (e.g. `mvn test -Djenkins.version=2.289`) and they seem to follow a simiular pattern

            calling HTMLUnit's `click` to submit a form is resulting in Jenkins erroring with something like

            {noformat}
              15.170 [id=94] WARNING o.e.j.s.h.ContextHandler$Context#log: Error while serving http://localhost:64686/jenkins/job/testFolder/support/generateAndDownload
            net.sf.json.JSONException: A JSONObject text must begin with '{' at character 1 of init
                    at net.sf.json.util.JSONTokener.syntaxError(JSONTokener.java:499)
                    at net.sf.json.JSONObject._fromJSONTokener(JSONObject.java:919)
            ...
            {noformat}

            which subsequently causes the test to fail.

            On the surface this appears to be an incompatability between HTMLUnit and Jenkins bumping to the latest HTMLUnit seemed to make no difference.

            So far observed the issue in
            * support-core
            * ldap
            Several plugins have failing tests when using new versions of core (e.g. `mvn test -Djenkins.version=2.289`) and they seem to follow a simiular pattern

            calling HTMLUnit's `click` to submit a form is resulting in Jenkins erroring with something like

            {noformat}
              15.170 [id=94] WARNING o.e.j.s.h.ContextHandler$Context#log: Error while serving http://localhost:64686/jenkins/job/testFolder/support/generateAndDownload
            net.sf.json.JSONException: A JSONObject text must begin with '{' at character 1 of init
                    at net.sf.json.util.JSONTokener.syntaxError(JSONTokener.java:499)
                    at net.sf.json.JSONObject._fromJSONTokener(JSONObject.java:919)
            ...
            {noformat}

            which subsequently causes the test to fail.

            On the surface this appears to be an incompatability between HTMLUnit and Jenkins bumping to the latest HTMLUnit seemed to make no difference.

            So far observed the issue in
            * support-core
            * ldap
            * ssh-slaves
            raihaan Raihaan Shouhell added a comment -

            This should be the issue that is breaking pipeline-input and pipeline-model-definition as well.

            Possibly related: https://github.com/jenkinsci/jenkins/pull/5405

            raihaan Raihaan Shouhell made changes -
            Summary incompatability between FormSubmission and HTMLUnit post Jenksin 2.289 incompatability between FormSubmission and HTMLUnit post Jenkins 2.289
            teilo James Nord made changes -
            Description Several plugins have failing tests when using new versions of core (e.g. `mvn test -Djenkins.version=2.289`) and they seem to follow a simiular pattern

            calling HTMLUnit's `click` to submit a form is resulting in Jenkins erroring with something like

            {noformat}
              15.170 [id=94] WARNING o.e.j.s.h.ContextHandler$Context#log: Error while serving http://localhost:64686/jenkins/job/testFolder/support/generateAndDownload
            net.sf.json.JSONException: A JSONObject text must begin with '{' at character 1 of init
                    at net.sf.json.util.JSONTokener.syntaxError(JSONTokener.java:499)
                    at net.sf.json.JSONObject._fromJSONTokener(JSONObject.java:919)
            ...
            {noformat}

            which subsequently causes the test to fail.

            On the surface this appears to be an incompatability between HTMLUnit and Jenkins bumping to the latest HTMLUnit seemed to make no difference.

            So far observed the issue in
            * support-core
            * ldap
            * ssh-slaves
            Several plugins have failing tests when using new versions of core (e.g. `mvn test -Djenkins.version=2.289`) and they seem to follow a simiular pattern

            calling HTMLUnit's `click` to submit a form is resulting in Jenkins erroring with something like

            {noformat}
              15.170 [id=94] WARNING o.e.j.s.h.ContextHandler$Context#log: Error while serving http://localhost:64686/jenkins/job/testFolder/support/generateAndDownload
            net.sf.json.JSONException: A JSONObject text must begin with '{' at character 1 of init
                    at net.sf.json.util.JSONTokener.syntaxError(JSONTokener.java:499)
                    at net.sf.json.JSONObject._fromJSONTokener(JSONObject.java:919)
            ...
            {noformat}

            which subsequently causes the test to fail.

            On the surface this appears to be an incompatability between HTMLUnit and Jenkins bumping to the latest HTMLUnit seemed to make no difference.

            So far observed the issue in
            * support-core
            * ldap
            * ssh-slaves
            * pipeline-input-step
            teilo James Nord made changes -
            Link This issue is caused by JENKINS-53462 [ JENKINS-53462 ]
            teilo James Nord added a comment -
            tom_gl Thomas de Grenier de Latour added a comment -

            I've shared some findings and experiments here: https://github.com/jenkinsci/jenkins/pull/5479

            markewaite Mark Waite added a comment -

            I believe the change also caused the save of a matrix job to never return. I'm able to save the specific matrix project in Jenkins 2.288 but not in 2.289 through 2.293.

            When I revert the non-trusted submit event change, then I am able to save it with 2.289-SNAPSHOT.

            The change in PR-5479 from Thomas de Grenier de Latour in a Jenkins 2.294 snapshot build did not resolve the issue I saw when saving a matrix job. See https://github.com/jenkinsci/jenkins/pull/5405#issuecomment-842713911 for details

            tom_gl Thomas de Grenier de Latour added a comment -

            PR-5479, fixing failing HtmlUnit tests as well as some jobs configuration not saving, is merged. Should be released in 2.296 next week.

            Hopefully it can then be included in LTS 2.289.2 (with a revert of the revert of JENKINS-53462 / PR-5405).

            tom_gl Thomas de Grenier de Latour made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Fixed but Unreleased [ 10203 ]
            tom_gl Thomas de Grenier de Latour made changes -
            Labels lts-candidate
            tom_gl Thomas de Grenier de Latour made changes -
            Released As https://github.com/jenkinsci/jenkins/releases/tag/jenkins-2.296
            Status Fixed but Unreleased [ 10203 ] Resolved [ 5 ]
            timja Tim Jacomb made changes -
            Labels lts-candidate 2.289.2-fixed lts-candidate
            timja Tim Jacomb made changes -
            Labels 2.289.2-fixed lts-candidate 2.289.2-fixed
            markewaite Mark Waite made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              teilo James Nord
              Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: