Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-65757

Jenkins 2.295 fails to start

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: jacoco-plugin
    • Labels:
      None
    • Environment:
      Jenkins fails to start after upgrade to 2.295 and JaCoCo plugin upgraded to 3.2.0
    • Similar Issues:
    • Released As:
      3.3.0

      Description

      After upgrading to the latest (2.295) and plugins (lots of them), the Jenkins refuses to start, giving me the error page (see the attachment).

       

      I tried to revert to 2.291 (the latest working before the upgrade) but it also gives me errors.

        Attachments

          Issue Links

            Activity

            lwiechec Lukasz Wiechec created issue -
            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Component/s git-plugin [ 15543 ]
            oleg_nenashev Oleg Nenashev made changes -
            Assignee Mark Waite [ markewaite ]
            oleg_nenashev Oleg Nenashev added a comment -

            Mark Waitethe stacktrace says that then failure is caused by NPE in Git Pl;ugin.

            Looking into it

            oleg_nenashev Oleg Nenashev added a comment -

            https://github.com/jenkinsci/git-plugin/blob/master/src/main/java/hudson/plugins/git/GitSCM.java#L2119-L2132 suggests that something is really wrong with initialization of this instance 

             

            Lukasz Wiechec please provide full startup log before the instance fails

            lwiechec Lukasz Wiechec made changes -
            Comment [ jenkins.err.log added to the Attachments ]
            lwiechec Lukasz Wiechec made changes -
            Attachment jenkins.err.log [ 54904 ]
            lwiechec Lukasz Wiechec added a comment -

            thanks for looking into it; startup log added to the 'Attachment' section above

            markewaite Mark Waite added a comment - - edited

            I saw mention in a mailing list message that a guice upgrade was introduced in a specific plugin and that may have caused startup issues. The Jenkins users mailing list "Upgraded Plugins: Jenkins fails to start" describes that the jacoco plugin upgraded to a newer version of the guice dependency and one user reported that a rollback was required for their environment.

            Lukasz Wiechec, could you review the recently updated plugins in your installation?

            My installation of Jenkins 2.295 with the latest JaCoCo plugin does not show the problem with either Java 8 or Java 11, but that could be more of a happy accident than expected result.

            Are you using the JaCoCo plugin and if so, what version?

            Does the problem resolve itself if you downgrade to an older version of the JaCoCo plugin?

            markewaite Mark Waite made changes -
            Assignee Mark Waite [ markewaite ]
            lwiechec Lukasz Wiechec added a comment - - edited

            Mark Waite thanks for a very valuable information! JaCoCo plugin 3.2.0 seems to be the issue here; when I remove it from the %JENKINS%\plugins, Jenkins manages to start.

             

            I have changed the description of this ticket a bit, and added the jacoco-pluing tag.

             

             

            lwiechec Lukasz Wiechec made changes -
            Component/s jacoco-plugin [ 16541 ]
            Environment Jenkins fails to start after upgrade to 2.295, together with some plugins Jenkins fails to start after upgrade to 2.295 and JaCoCo plugin upgraded to 3.2.0
            markewaite Mark Waite made changes -
            Component/s git-plugin [ 15543 ]
            marcorobiati Marco added a comment -

            why did you remove the git-plugin tag if the error clealry states it's form the git-plugin?

            lwiechec Lukasz Wiechec added a comment - - edited

            Marco indeed - I re-added it.

            lwiechec Lukasz Wiechec made changes -
            Component/s git-plugin [ 15543 ]
            markewaite Mark Waite added a comment -

            I removed the git plugin because we prefer to assign issues to the root cause plugin rather than assigning issues to each plugin that is affected by the issue. In this case, I believe the jacoco plugin is the root cause. If we continue to collect every plugin that is harmed by this change to the jacoco plugin, we may have a very long list of plugins associated with this issue.

            However, I won't wrestle with others about plugin assignment. If you feel strongly that the git plugin should be assigned, you're welcome to do that.

            marcorobiati Marco added a comment -

            I was in a hurry yesterday and I realize only now that I seemed a bit rude, that wasn't my intention, sorry.

            I asked because I got the same error message after installing bitbucket-plugin (which has git-plugin as dependency along with many other) on both latest and latest stable release of Jenkins, although using the jenkins.war on tomcat with java 16 which I know is not supported.

            So I was just hoping this could lead to solving the issues even for my case.

            I managed to use jenkins (latest stable) in tomcat 9 with java 16 till with those 2 plugins till 2 days ago, when I upgraded tomcat to version 10 and had to use their tool to migrate .war files for their newer version. It started, but gave me the same error message after installing those plugins.

            Anyway considering I'm using not supported software I won't have any word on this. and anyway Mark you have a good point I won't wrestle with anything, that wasn't my intention I was merely curious but I realize I didn't use the best approach

            I'll see if I can test all of this with a supported java version

             

            jglick Jesse Glick made changes -
            Component/s core [ 15593 ]
            Component/s git-plugin [ 15543 ]
            marcorobiati Marco added a comment -

            Installed on CentOS 8, via repository (running with it's embedded Jetty container), latest version and run with latest OpenJDK 11, same plugin as before, no problem so far

            markewaite Mark Waite added a comment -

            Marco not interpreted as rude at all. You asked a very good question. I'm also unable to duplicate the problem, but I believe the problem is real as reported in the JaCoCo plugin. I don't know the conditions that cause the failure, but I could understand that having two incompatible versions of a Java library might very well cause problems in some cases and work in other cases.

            orzechszek orzech szek added a comment -

            I have similar problem with:

            • jacoco 3.2.0
            • rest of plugins in the latest version
            • jenkins 2.293
            2021-05-23 16:50:09.041+0000 [id=36]    SEVERE  h.ExtensionFinder$GuiceFinder#<init>: Failed to create Guice container from all the pluginsjava.lang.LinkageError: loader constraint violation: loader (instance of hudson/PluginFirstClassLoader) previously initiated loading for a different type with name "com/google/inject/Binder"        at java.lang.ClassLoader.defineClass1(Native Method)        at java.lang.ClassLoader.defineClass(ClassLoader.java:763)        at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1155)        at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1326)        at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1377)        at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1342)        at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1095)        at java.lang.ClassLoader.loadClass(ClassLoader.java:357)        at com.google.inject.multibindings.Multibinder.newSetBinder(Multibinder.java:136)        at com.google.inject.multibindings.Multibinder.newSetBinder(Multibinder.java:99)        at hudson.plugins.depgraph_view.model.graph.DependencyGraphModule.configure(DependencyGraphModule.java:49)        at com.google.inject.AbstractModule.configure(AbstractModule.java:62)        at com.google.inject.spi.Elements$RecordingBinder.install(Elements.java:340)        at com.google.inject.spi.Elements.getElements(Elements.java:110)        at com.google.inject.internal.InjectorShell$Builder.build(InjectorShell.java:138)        at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:104)        at com.google.inject.Guice.createInjector(Guice.java:96)        at com.google.inject.Guice.createInjector(Guice.java:73)        at hudson.ExtensionFinder$GuiceFinder.<init>(ExtensionFinder.java:285)        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)        at java.lang.reflect.Constructor.newInstance(Constructor.java:423)        at java.lang.Class.newInstance(Class.java:442)        at net.java.sezpoz.IndexItem.instance(IndexItem.java:181)        at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:703)        at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:689)        at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:349)        at hudson.ExtensionList.load(ExtensionList.java:381)        at hudson.ExtensionList.ensureLoaded(ExtensionList.java:317)        at hudson.ExtensionList.getComponents(ExtensionList.java:183)        at jenkins.model.Jenkins$6.onInitMilestoneAttained(Jenkins.java:1161)        at jenkins.InitReactorRunner$1.onAttained(InitReactorRunner.java:84)        at org.jvnet.hudson.reactor.ReactorListener$Aggregator.lambda$onAttained$3(ReactorListener.java:102)        at org.jvnet.hudson.reactor.ReactorListener$Aggregator.run(ReactorListener.java:109)        at org.jvnet.hudson.reactor.ReactorListener$Aggregator.onAttained(ReactorListener.java:102)        at org.jvnet.hudson.reactor.Reactor$1.run(Reactor.java:177)        at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)        at jenkins.security.ImpersonatingExecutorService$1.run(ImpersonatingExecutorService.java:68)        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)        at java.lang.Thread.run(Thread.java:748)2021-05-23 16:50:09.657+0000 [id=36]    WARNING hudson.ExtensionFinder$Sezpoz#_find: Failed to load hudson.ExtensionFinder$GuiceFindercom.google.inject.CreationException: Unable to create injector, see the following errors: 1) Could not find a suitable constructor in jenkins.model.Jenkins. Classes must have either one (and only one) constructor annotated with @Inject or a zero-argument constructor that is not private.  at jenkins.model.Jenkins.class(Jenkins.java:314)  while locating jenkins.model.Jenkins    for field at jenkins.model.Jenkins$EnforceSlaveAgentPortAdministrativeMonitor.j(Jenkins.java:1321)  at hudson.ExtensionFinder$GuiceFinder$SezpozModule.configure(ExtensionFinder.java:527) 2) Could not find a suitable constructor in jenkins.model.Jenkins. Classes must have either one (and only one) constructor annotated with @Inject or a zero-argument constructor that is not private.  at jenkins.model.Jenkins.class(Jenkins.java:314)  while locating jenkins.model.Jenkins    for field at jenkins.security.s2m.AdminCallableMonitor.jenkins(AdminCallableMonitor.java:33)  at hudson.ExtensionFinder$GuiceFinder$SezpozModule.configure(ExtensionFinder.java:527) 3) Could not find a suitable constructor in jenkins.model.Jenkins. Classes must have either one (and only one) constructor annotated with @Inject or a zero-argument constructor that is not private.  at jenkins.model.Jenkins.class(Jenkins.java:314)  while locating jenkins.model.Jenkins    for field at jenkins.security.s2m.MasterKillSwitchConfiguration.jenkins(MasterKillSwitchConfiguration.java:20)  at hudson.ExtensionFinder$GuiceFinder$SezpozModule.configure(ExtensionFinder.java:527) 3 errors        at com.google.inject.internal.Errors.throwCreationExceptionIfErrorsExist(Errors.java:466)        at com.google.inject.internal.InternalInjectorCreator.initializeStatically(InternalInjectorCreator.java:155)        at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:107)        at com.google.inject.Guice.createInjector(Guice.java:96)        at com.google.inject.Guice.createInjector(Guice.java:73)        at com.google.inject.Guice.createInjector(Guice.java:62)        at hudson.ExtensionFinder$GuiceFinder.<init>(ExtensionFinder.java:291)        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)        at java.lang.reflect.Constructor.newInstance(Constructor.java:423)        at java.lang.Class.newInstance(Class.java:442)        at net.java.sezpoz.IndexItem.instance(IndexItem.java:181)Caused: java.lang.InstantiationException        at net.java.sezpoz.IndexItem.instance(IndexItem.java:191)        at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:703)        at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:689)        at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:349)        at hudson.ExtensionList.load(ExtensionList.java:381)        at hudson.ExtensionList.ensureLoaded(ExtensionList.java:317)        at hudson.ExtensionList.getComponents(ExtensionList.java:183)        at jenkins.model.Jenkins$6.onInitMilestoneAttained(Jenkins.java:1161)        at jenkins.InitReactorRunner$1.onAttained(InitReactorRunner.java:84)        at org.jvnet.hudson.reactor.ReactorListener$Aggregator.lambda$onAttained$3(ReactorListener.java:102)        at org.jvnet.hudson.reactor.ReactorListener$Aggregator.run(ReactorListener.java:109)        at org.jvnet.hudson.reactor.ReactorListener$Aggregator.onAttained(ReactorListener.java:102)        at org.jvnet.hudson.reactor.Reactor$1.run(Reactor.java:177)        at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)        at jenkins.security.ImpersonatingExecutorService$1.run(ImpersonatingExecutorService.java:68)        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)        at java.lang.Thread.run(Thread.java:748)2021-05-23 16:50:09.672+0000 [id=36]    INFO    jenkins.InitReactorRunner$1#onAttained: Prepared all plugins2021-05-23 16:50:09.673+0000 [id=36]    SEVERE  jenkins.InitReactorRunner$1#onTaskFailed: Failed Contributed.loadjava.lang.NullPointerException        at jenkins.security.CustomClassFilter$Contributed.load(CustomClassFilter.java:155)Caused: java.lang.reflect.InvocationTargetException        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)        at java.lang.reflect.Method.invoke(Method.java:498)        at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:104)Caused: java.lang.Error        at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:110)        at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:175)        at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)        at jenkins.model.Jenkins$5.runTask(Jenkins.java:1131)        at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)        at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)        at jenkins.security.ImpersonatingExecutorService$1.run(ImpersonatingExecutorService.java:68)        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)        at java.lang.Thread.run(Thread.java:748)2021-05-23 16:50:09.684+0000 [id=33]    SEVERE  jenkins.InitReactorRunner$1#onTaskFailed: Failed Initializing plugin chrootjava.lang.NullPointerException        at org.jenkinsci.plugins.chroot.tools.ChrootToolset.list(ChrootToolset.java:146)        at org.jenkinsci.plugins.chroot.tools.ChrootToolset.isEmpty(ChrootToolset.java:142)        at org.jenkinsci.plugins.chroot.Chroot.postInitialize(Chroot.java:39)        at hudson.PluginManager$2$1$2.run(PluginManager.java:575)        at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)        at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)        at jenkins.model.Jenkins$5.runTask(Jenkins.java:1131)        at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)        at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)        at jenkins.security.ImpersonatingExecutorService$1.run(ImpersonatingExecutorService.java:68)        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)        at java.lang.Thread.run(Thread.java:748)2021-05-23 16:50:09.688+0000 [id=34]    SEVERE  jenkins.InitReactorRunner$1#onTaskFailed: Failed Initializing plugin jenkins-jira-pluginjava.lang.AssertionError: class org.marvelution.jji.configuration.JiraSitesConfiguration is missing its descriptor        at jenkins.model.Jenkins.getDescriptorOrDie(Jenkins.java:1599)        at org.marvelution.jji.configuration.JiraSitesConfiguration.get(JiraSitesConfiguration.java:47)        at org.marvelution.jji.security.SyncTokenAuthenticationFilter.<init>(SyncTokenAuthenticationFilter.java:50)        at org.marvelution.jji.JiraPlugin.postInitialize(JiraPlugin.java:72)        at hudson.PluginManager$2$1$2.run(PluginManager.java:575)        at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)        at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)        at jenkins.model.Jenkins$5.runTask(Jenkins.java:1131)        at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)        at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)        at jenkins.security.ImpersonatingExecutorService$1.run(ImpersonatingExecutorService.java:68)        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)        at java.lang.Thread.run(Thread.java:748)2021-05-23 16:50:09.973+0000 [id=30]    INFO    jenkins.InitReactorRunner$1#onAttained: Started all plugins2021-05-23 16:50:09.974+0000 [id=28]    SEVERE  jenkins.InitReactorRunner$1#onTaskFailed: Failed UserIdMapper.initjava.lang.IllegalArgumentException: Unable to inject class hudson.model.UserIdMapper        at hudson.init.TaskMethodFinder.lookUp(TaskMethodFinder.java:125)        at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:105)        at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:175)        at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)        at jenkins.model.Jenkins$5.runTask(Jenkins.java:1131)        at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)        at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)        at jenkins.security.ImpersonatingExecutorService$1.run(ImpersonatingExecutorService.java:68)        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)        at java.lang.Thread.run(Thread.java:748)2021-05-23 16:50:09.974+0000 [id=33]    SEVERE  jenkins.InitReactorRunner$1#onTaskFailed: Failed PluginImpl.initjava.lang.IllegalStateException: Expected 1 instance of hudson.PluginManager$PluginUpdateMonitor but got 0        at hudson.ExtensionList.lookupSingleton(ExtensionList.java:451)        at hudson.PluginManager$PluginUpdateMonitor.getInstance(PluginManager.java:2304)        at hudson.maven.PluginImpl.init(PluginImpl.java:58)Caused: java.lang.reflect.InvocationTargetException        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)        at java.lang.reflect.Method.invoke(Method.java:498)        at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:104)Caused: java.lang.Error        at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:110)        at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:175)        at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)        at jenkins.model.Jenkins$5.runTask(Jenkins.java:1131)        at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)        at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)        at jenkins.security.ImpersonatingExecutorService$1.run(ImpersonatingExecutorService.java:68)        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)        at java.lang.Thread.run(Thread.java:748)2021-05-23 16:50:09.976+0000 [id=22]    SEVERE  hudson.util.BootFailure#publish: Failed to initialize Jenkinsjava.lang.IllegalArgumentException: Unable to inject class hudson.model.UserIdMapper        at hudson.init.TaskMethodFinder.lookUp(TaskMethodFinder.java:125)        at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:105)        at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:175)        at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)        at jenkins.model.Jenkins$5.runTask(Jenkins.java:1131)        at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)        at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)        at jenkins.security.ImpersonatingExecutorService$1.run(ImpersonatingExecutorService.java:68)        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)        at java.lang.Thread.run(Thread.java:748)Caused: org.jvnet.hudson.reactor.ReactorException        at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:282)        at jenkins.InitReactorRunner.run(InitReactorRunner.java:49)        at jenkins.model.Jenkins.executeReactor(Jenkins.java:1164)        at jenkins.model.Jenkins.<init>(Jenkins.java:962)        at hudson.model.Hudson.<init>(Hudson.java:85)        at hudson.model.Hudson.<init>(Hudson.java:81)        at hudson.WebAppMain$3.run(WebAppMain.java:295)Caused: hudson.util.HudsonFailedToLoad        at hudson.WebAppMain$3.run(WebAppMain.java:312)2021-05-23 16:50:09.986+0000 [id=22]    INFO    jenkins.model.Jenkins#cleanUp: Stopping Jenkins2021-05-23 16:50:10.027+0000 [id=22]    INFO    jenkins.model.Jenkins$18#onAttained: Started termination2021-05-23 16:50:10.039+0000 [id=22]    INFO    c.a.s.j.p.d.cache.BuildCache#stopGarbageCollector: Stopping GC scheduling2021-05-23 16:50:10.040+0000 [id=22]    INFO    c.a.s.j.p.d.cache.BuildCache#stopWorkerThread: Stopping Worker Thread Pool...2021-05-23 16:50:10.040+0000 [id=22]    SEVERE  jenkins.model.Jenkins$18#onTaskFailed: Failed BuildCache.stopjava.lang.NullPointerException        at com.axis.system.jenkins.plugins.downstream.cache.BuildCache.stopWorkerThread(BuildCache.java:298)        at com.axis.system.jenkins.plugins.downstream.cache.BuildCache.stop(BuildCache.java:81)Caused: java.lang.reflect.InvocationTargetException        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)        at java.lang.reflect.Method.invoke(Method.java:498)        at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:104)Caused: java.lang.Error        at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:110)        at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:175)        at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)        at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)        at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)        at jenkins.model.Jenkins$17.execute(Jenkins.java:3507)        at org.jvnet.hudson.reactor.Reactor$Node.runIfPossible(Reactor.java:139)        at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:128)        at jenkins.model.Jenkins$17.execute(Jenkins.java:3507)        at org.jvnet.hudson.reactor.Reactor$Node.runIfPossible(Reactor.java:139)        at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:276)        at jenkins.model.Jenkins._cleanUpRunTerminators(Jenkins.java:3504)        at jenkins.model.Jenkins.cleanUp(Jenkins.java:3429)        at hudson.WebAppMain$3.run(WebAppMain.java:316)2021-05-23 16:50:10.040+0000 [id=22]    SEVERE  jenkins.model.Jenkins$18#onTaskFailed: Failed IOHubProvider.cleanUpjava.lang.IllegalArgumentException: Unable to inject class jenkins.slaves.IOHubProvider        at hudson.init.TaskMethodFinder.lookUp(TaskMethodFinder.java:125)        at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:105)        at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:175)        at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)        at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)        at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)        at jenkins.model.Jenkins$17.execute(Jenkins.java:3507)        at org.jvnet.hudson.reactor.Reactor$Node.runIfPossible(Reactor.java:139)        at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:128)        at jenkins.model.Jenkins$17.execute(Jenkins.java:3507)        at org.jvnet.hudson.reactor.Reactor$Node.runIfPossible(Reactor.java:139)        at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:276)        at jenkins.model.Jenkins._cleanUpRunTerminators(Jenkins.java:3504)        at jenkins.model.Jenkins.cleanUp(Jenkins.java:3429)        at hudson.WebAppMain$3.run(WebAppMain.java:316)2021-05-23 16:50:10.041+0000 [id=22]    SEVERE  jenkins.model.Jenkins$18#onTaskFailed: Failed NioChannelSelector.cleanUpjava.lang.IllegalArgumentException: Unable to inject class jenkins.slaves.NioChannelSelector        at hudson.init.TaskMethodFinder.lookUp(TaskMethodFinder.java:125)        at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:105)        at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:175)        at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)        at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)        at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)        at jenkins.model.Jenkins$17.execute(Jenkins.java:3507)        at org.jvnet.hudson.reactor.Reactor$Node.runIfPossible(Reactor.java:139)        at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:128)        at jenkins.model.Jenkins$17.execute(Jenkins.java:3507)        at org.jvnet.hudson.reactor.Reactor$Node.runIfPossible(Reactor.java:139)        at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:276)        at jenkins.model.Jenkins._cleanUpRunTerminators(Jenkins.java:3504)        at jenkins.model.Jenkins.cleanUp(Jenkins.java:3429)        at hudson.WebAppMain$3.run(WebAppMain.java:316)2021-05-23 16:50:10.047+0000 [id=22]    INFO    jenkins.model.Jenkins$18#onAttained: Completed termination2021-05-23 16:50:10.047+0000 [id=22]    INFO    jenkins.model.Jenkins#_cleanUpDisconnectComputers: Starting node disconnection2021-05-23 16:50:10.048+0000 [id=22]    INFO    jenkins.model.Jenkins#_cleanUpShutdownPluginManager: Stopping plugin manager2021-05-23 16:50:10.173+0000 [id=22]    INFO    jenkins.model.Jenkins#_cleanUpPersistQueue: Persisting build queue2021-05-23 16:50:10.654+0000 [id=22]    INFO    jenkins.model.Jenkins#cleanUp: Jenkins stopped
            

            Revert jacoco to version 3.1.1  helped - jenkins start normally.

             

            teilo James Nord made changes -
            Assignee James Nord [ teilo ]
            teilo James Nord made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            teilo James Nord made changes -
            Component/s core [ 15593 ]
            teilo James Nord made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            teilo James Nord made changes -
            Remote Link This issue links to "jacoco PR#151 (Web Link)" [ 26776 ]
            teilo James Nord added a comment - - edited

            until it gets garbage collected there is a build of the PR available from https://repo.jenkins-ci.org/artifactory/snapshots/org/jenkins-ci/plugins/jacoco/3.2.1-SNAPSHOT/jacoco-3.2.1-20210607.213800-1.hpi if anyone wants to test this and provide feedback that the plugin still works to record jacoco coverage and does not cause the failure of other plugins.

            or from CI -> https://ci.jenkins.io/job/Plugins/job/jacoco-plugin/job/PR-151/lastStableBuild/artifact/target/jacoco.hpi

            markewaite Mark Waite added a comment -

            I loaded the PR build into my Jenkins instance and verified that the platformlabeler plugin job that I have enabled for jacoco coverage reporting still reports the expected results. Coverage reports can be navigated, lines covered and uncovered are visible, and the plugin behaves as expected. Thanks James Nord!

            lwiechec Lukasz Wiechec added a comment -

            James Nord after installing the JaCoCo plugin from PR-151 branch my Jenkins starts normally - thanks!

            jglick Jesse Glick made changes -
            Component/s core [ 15593 ]
            jglick Jesse Glick made changes -
            Released As 3.3.0
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Resolved [ 5 ]

              People

              Assignee:
              teilo James Nord
              Reporter:
              lwiechec Lukasz Wiechec
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: