Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1044

Add option for 'private m2 repository'

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: Macintosh, OS: All
    • Similar Issues:

      Description

      We set up hudson to have some of our projects use 'private' repositories, where the repository is a part
      of the build workspace. This causes all dependencies to be re-downloaded, and accurately shows what
      would havppen if a 'new developer' started work. This checks that there is nothing that is lying around
      in a repository that isn't properly specified in a repository.

      to do this, we add something like
      -Dmaven.repo.local=E:\tomcat-home\.hudson\jobs\Nightly_US\workspace\trunk\localRepository
      to the maven options. But this relies on knowing where the workspace is going to be on disk, so only
      people that understand that can get it set up.

      It'd be spiffy to have a 'use private repository' button on the m2 settings, and a 'clear repository every
      build' option.

      Additionally, because m2 projects can't be run in parallel (because local repositories aren't thread safe),
      we only ever have 1 project build at once. But for projects that 'use private repository', multiple could
      be built at once - this would be a useful option (only build private repositories in parallel).

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/www/changelog.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=10149
            Log:
            [FIXED] .. and also JENKINS-1044.

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 421 has been marked as a duplicate of this issue. ***

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              magnayn magnayn
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: