Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1084

Build record time should be immutable

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: other
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      The build time stored in the Build record should be stored in some immutable
      format (e.g., an epoch-time long). This will forestall any weird bugs like the
      one in this thread:

      https://hudson.dev.java.net/servlets/ReadMsg?list=users&msgNo=5681

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 1247 has been marked as a duplicate of this issue. ***
            kohsuke Kohsuke Kawaguchi added a comment -

            After looking at the code, I modified the code to return a cloned Calendar in
            the getTimestamp() method, instead of using the long in the field.

            We really need a constructor in GregorianCalendar that takes long or Date.

            This fix is in 1.179.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              rsutphin rsutphin
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: