Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1177

RSS URL's in HTML HEAD point to wrong location

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: other
    • Labels:
      None
    • Environment:
      Platform: All, OS: Windows XP
    • Similar Issues:

      Description

      The link tag in the HTML HEAD part of the main document looks like this:
      <link type="application/rss+xml" rel="alternate" title="Hudson:All (all builds)"
      href="/rssAll"></link>
      However, this doesn't take into account that the application is actually
      deployed under the /hudson "directory" on the application server. I.e. the link
      should look like:
      <link type="application/rss+xml" rel="alternate" title="Hudson:All (all builds)"
      href="/hudson/rssAll"></link>

      This is for both the All builds and Failed Builds (along with the RSS2.0
      version) links. The link icons within the page itself are fine.

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -

            Thanks for catching those. Fixed in 1.172.

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 1173 has been marked as a duplicate of this issue. ***

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              davyboyhayes davyboyhayes
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: