Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11888

Jenkins CLI does not supports stopping jobs

    XMLWordPrintable

Details

    • New Feature
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • cli, core
    • Jenkins CLI does not supports stopping jobs
    • Jenkins 2.167

    Description

      Please add support of cancel job execution via Jenkins CLI. Something like
      $ java -jar jenkins-cli.jar -s http://[server]:8080/ stop [job name]

      Attachments

        Activity

          pxantom Oleksandr Popov created issue -
          pxantom Oleksandr Popov made changes -
          Field Original Value New Value
          Environment Jenkins CLI does not supports stoping jobs Jenkins CLI does not supports stopping jobs
          Summary Jenkins CLI does not supports stoping jobs Jenkins CLI does not supports stopping jobs

          Calling the command stop-job or cancel-job should make it relatively unambiguous.

          corneil_duplessis Corneil du Plessis added a comment - Calling the command stop-job or cancel-job should make it relatively unambiguous.
          oleg_nenashev Oleg Nenashev added a comment -

          The issue is actual

          oleg_nenashev Oleg Nenashev added a comment - The issue is actual
          oleg_nenashev Oleg Nenashev made changes -
          Component/s core [ 15593 ]
          danielbeck Daniel Beck added a comment -

          Not a bug.

          danielbeck Daniel Beck added a comment - Not a bug.
          danielbeck Daniel Beck made changes -
          Issue Type Bug [ 1 ] New Feature [ 2 ]
          kaltokri Rolf Geuenich added a comment -

          I would like to have this feature, too.
          Even if the request is 3 years old it can help to abort jobs with jenkinscli.

          kaltokri Rolf Geuenich added a comment - I would like to have this feature, too. Even if the request is 3 years old it can help to abort jobs with jenkinscli.
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 142131 ] JNJira + In-Review [ 175622 ]
          oleg_nenashev Oleg Nenashev made changes -
          Labels newbie-friendly
          oleg_nenashev Oleg Nenashev added a comment -

          It's pretty trivial to implement, assigned the newbie-friendly label

          oleg_nenashev Oleg Nenashev added a comment - It's pretty trivial to implement, assigned the newbie-friendly label
          austry Ilia Zasimov made changes -
          Assignee Ilia Zasimov [ austry ]
          austry Ilia Zasimov made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          austry Ilia Zasimov made changes -
          Status In Progress [ 3 ] In Review [ 10005 ]
          oleg_nenashev Oleg Nenashev added a comment -

          Released in 2.176

          Thanks austry!

          oleg_nenashev Oleg Nenashev added a comment - Released in 2.176 Thanks austry !
          oleg_nenashev Oleg Nenashev made changes -
          Released As Jenkins 2.167
          Resolution Fixed [ 1 ]
          Status In Review [ 10005 ] Resolved [ 5 ]

          People

            austry Ilia Zasimov
            pxantom Oleksandr Popov
            Votes:
            6 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: