Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13357

Autoinstall JDK from download.oracle.com no longer works

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Fixed
    • core
    • None

    Description

      Just noticed that the autoinstallation of JDK from download.oracle.com stopped working recently. I tried various Jenkins instances running here and they all have the same problem; versions 1.458 on Linux & Windows

      The downloaded 'jdk.exe' or 'jdh.sh' just contains a html page with the note 'Sorry! In order to download products from Oracle Technology
      Network you must agree to the OTN license terms.'

      The error on Windows build is then:

      Installing JDK jdk-7-oth-JPR
      Downloading JDK from http://download.oracle.com/otn/java/jdk/7/jdk-7-windows-i586.exe
      Downloading 5307bytes
      [jdk_1.7.0] $ C:\tools\jenkins\tools\jdk_1.7.0\jdk.exe /s /v /qn /L \"C:\tools\jenkins\tools\jdk_1.7.0\jdk.exe.install.log\" REBOOT=ReallySuppress INSTALLDIR=\"C:\tools\jenkins\tools\jdk_1.7.0\"
      The image file %1 is valid, but is for a machine type other than the current machine
      FATAL: Befehlsausf├╝hrung fehlgeschlagen
      java.io.IOException: Cannot run program "C:\tools\jenkins\tools\jdk_1.7.0\jdk.exe" (in directory "C:\tools\jenkins\tools\jdk_1.7.0"): CreateProcess error=216, This version of %1 is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need a x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher
      ...
      

      Attachments

        Issue Links

          Activity

            chemphill chemphill added a comment -

            We just upgraded to 1.556 and cleared out the cache. Looks like this is still happening:

            [EnvInject] - Loading node environment variables.
            Installing JDK jdk-8-oth-JPR
            Downloading JDK from http://download.oracle.com/otn-pub/java/jdk/8-b132/jdk-8-linux-x64.tar.gz
            Downloading 5307bytes
            Installing /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh
            [jdk-cbh] $ /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh -noregister
            /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 1: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open html: No such file
            /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 2: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open head: No such file
            /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 3: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open title: No such file
            /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 3: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: Request: not found
            /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 4: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open META: No such file
            /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 5: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open link: No such file
            /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 6: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open link: No such file
            /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 7: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh:
            : not found
            /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 8: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open body: No such file
            /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 9: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open div: No such file
            /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 10: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open table: No such file
            /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 11: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open tr: No such file
            /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 12: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: Syntax error: redirection unexpected
            ERROR: SEVERE ERROR occurs

            chemphill chemphill added a comment - We just upgraded to 1.556 and cleared out the cache. Looks like this is still happening: [EnvInject] - Loading node environment variables. Installing JDK jdk-8-oth-JPR Downloading JDK from http://download.oracle.com/otn-pub/java/jdk/8-b132/jdk-8-linux-x64.tar.gz Downloading 5307bytes Installing /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh [jdk-cbh] $ /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh -noregister /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 1: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open html: No such file /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 2: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open head: No such file /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 3: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open title: No such file /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 3: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: Request: not found /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 4: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open META: No such file /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 5: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open link: No such file /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 6: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open link: No such file /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 7: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: : not found /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 8: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open body: No such file /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 9: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open div: No such file /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 10: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open table: No such file /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 11: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: cannot open tr: No such file /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: 12: /var/lib/jenkins/tools/hudson.model.JDK/jdk-cbh/jdk.sh: Syntax error: redirection unexpected ERROR: SEVERE ERROR occurs

            Same error here, on an existent working version 1.542 which was working ok, and on a recently installed 1.555....any hint on why has this reappeared? is it an ORACLE issue?

            robertovieira Roberto Vieira added a comment - Same error here, on an existent working version 1.542 which was working ok, and on a recently installed 1.555....any hint on why has this reappeared? is it an ORACLE issue?
            jambo89liam Liam McGregor added a comment -

            Do you have an example of how the manually downloaded java files names and directories must be?

            jambo89liam Liam McGregor added a comment - Do you have an example of how the manually downloaded java files names and directories must be?
            javaes Jan van Esdonk added a comment - - edited

            Same issue here. In which format do I have to put the manually downloaded JDK into the (master's?) cache directory for the workaround, my Jenkins doesn't seem to recognize it.

            Edit: After installing default-jdk via apt on Debian, the Jenkins slave was able to download JDK1.7.0_25

            javaes Jan van Esdonk added a comment - - edited Same issue here. In which format do I have to put the manually downloaded JDK into the (master's?) cache directory for the workaround, my Jenkins doesn't seem to recognize it. Edit: After installing default-jdk via apt on Debian, the Jenkins slave was able to download JDK1.7.0_25
            danielbeck Daniel Beck added a comment -

            In 1.557, Jenkins adjusted to a change in Oracle's web site to be again able to download installers. Tracked as JENKINS-22347.

            If you encounter an issue similar to this one on a recent Jenkins version, please file a new issue instead of reopening this one. The cause is probably a different one. Thanks!

            danielbeck Daniel Beck added a comment - In 1.557, Jenkins adjusted to a change in Oracle's web site to be again able to download installers. Tracked as JENKINS-22347 . If you encounter an issue similar to this one on a recent Jenkins version, please file a new issue instead of reopening this one. The cause is probably a different one. Thanks!

            People

              kohsuke Kohsuke Kawaguchi
              andreasmandel Andreas Mandel
              Votes:
              16 Vote for this issue
              Watchers:
              18 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: