Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13459

yum update from 1.458 to 1.460 breaks Jenkins

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
    • Environment:
      RedHat Enterprise Linux 6.2 with Oracle Java 1.6.0_31 or OpenJava 1.6.0
    • Similar Issues:

      Description

      After yum update that downloaded and installed 1.460 the following shows in jenkins.log
      Apr 15, 2012 9:03:54 PM winstone.Logger logInternal
      SEVERE: Error initializing web application: prefix []
      java.io.FileNotFoundException: /var/cache/jenkins/war/META-INF/MANIFEST.MF (No such file or directory)
      at java.io.FileOutputStream.open(Native Method)
      .. etc..
      and Jenkins does not start.
      The directory /var/cache/jenkins/ is empty
      Running mkdir /var/cache/jenkins/war; cd /var/cache/jenkins/war; jar -xvf /usr/lib/jenkins/jenkins.war; chmod a+w ./
      and restarting jenkins via the /etc/inid.d/jenkins script works.

        Attachments

          Activity

          anand_sathe Anand Sathe added a comment -

          Same problem observed on EC2 Base Linux Image

          evernat evernat added a comment -

          Is it reproduced with a recent Jenkins version?

          chris_jones Chris Jones added a comment -

          Not that I have seen. (Up to and including 1.510)

          anand_sathe Anand Sathe added a comment -

          Has worked fine since 1.460

          evernat evernat added a comment -

          Ok, thanks.
          So resolving this issue as can not reproduce.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            chris_jones Chris Jones
            Votes:
            2 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: