Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14465

Buttons and lists don't work as expected

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Ubuntu 12.04
      Jenkins 1.474
      Run Condition Plugin 0.10
      Token Macro Plugin 1.5.1
      Conditional Buildstep 1.1
    • Similar Issues:

      Description

      When configuring a build step and selecting conditional steps (multiple), any option in the dropdown list for the condition is not functioning.
      If I select Execute Shell from this list, no box to write the shell script appears. Same happens with all the other options.
      More, I cannot delete this build step; the delete button simply does nothing, the Advanced button does nothing.

      I attached some pics to understand better.

        Attachments

        1. buttons.jpg
          buttons.jpg
          100 kB
        2. javascript-error.jpg
          javascript-error.jpg
          105 kB
        3. Jekins Java script error condition Multiple..jpg
          Jekins Java script error condition Multiple..jpg
          30 kB
        4. Jenkins No String1 and String 2.jpg
          Jenkins No String1 and String 2.jpg
          31 kB
        5. jenkins-plugins.png
          jenkins-plugins.png
          41 kB
        6. option-list.png
          option-list.png
          19 kB
        7. option-list1.png
          option-list1.png
          22 kB
        8. plugin_fail(1).png
          plugin_fail(1).png
          14 kB
        9. plugin_fail(2).png
          plugin_fail(2).png
          14 kB

          Issue Links

            Activity

            pxantom Oleksandr Popov added a comment -

            Have the similar issue. Checked in Firefox and IE. Same result.
            Please advice about progress.

            pxantom Oleksandr Popov added a comment - - edited

            Also I see that similar things happens with editing Views: Im unable to delete column by pressing "Delete" button.

            pxantom Oleksandr Popov added a comment -

            One additional update:
            When adding single conditional step it is working fine. For some reason in multiple steps (Ive attached screen shot of it)

            ace Adrian Vlad added a comment -

            For single conditional step, the trigger other jobs step or send files or commands over SSH step is not working fine. No text area for writing jobs appears, no scrollable list for selecting a server appears.

            domi Dominik Bartholdi added a comment -

            I'm not sure yet, but this might be caused by this change: https://github.com/jenkinsci/jenkins/commit/96442cd9cd7b432a19d05dd945502a854541cae7

            ...I'm a bit short in time right now, so not sure when I can have a look at this...

            pxantom Oleksandr Popov added a comment -

            Hi,

            @Adrian: from my side everything you posted (i.e. "For single conditional step, the trigger other jobs step or send files or commands over SSH step is not working fine") is working. Im able to choose servers and writing area appears (see screenshot)

            @domi: please see same screenshot thereis java script exeption when Im adding multiple conditional step. Hope that helps resolve issue

            ace Adrian Vlad added a comment -

            I've attached some screens with what I've said in previous post.
            For the second one, the one with SSH connection, the button Add Server appears but is not functioning; pressing it doesn't do anything.

            eyalzf Eyal Zfira added a comment -

            Also happening in 'Publish Over SSH', 'Sectioned View' & 'Promoted builds' plugins
            Very annoying...

            eyalzf Eyal Zfira added a comment -

            Got the following JavaScript errors when using the 'Sectioned view' plugin and adding a section:

            Uncaught TypeError: Object #<HTMLTextAreaElement> has no method 'createTextRange' codemirror.js:2050
            setSelRange codemirror.js:2050
            prepareInput codemirror.js:624

            Uncaught TypeError: Cannot call method 'hasClassName' of undefined hetero-list.js:17
            Behaviour.list.unshift.DIV.hetero-list-container hetero-list.js:17
            apply behavior.js:73
            (anonymous function) behavior.js:79
            Behaviour.applySubtree behavior.js:68
            menuButton.getMenu.renderEvent.subscribe.i hetero-list.js:108
            (anonymous function) hudson-behavior.js:519
            next hudson-behavior.js:558
            script.onload.script.onreadystatechange hudson-behavior.js:2016

            jglick Jesse Glick added a comment -

            May be related to JENKINS-14514, though I do not seem to be able to reproduce this issue.

            reddy123 Reddy kasireddy added a comment -

            Unable to setup the String 1 and String 2 parameters using the condition step (Multiple), I tried in firefox and Chrome no luck, attached java script error

            domi Dominik Bartholdi added a comment -

            this was a bug caused by a refactoring in the core, this is now fixed with core 1.477


              People

              Assignee:
              domi Dominik Bartholdi
              Reporter:
              ace Adrian Vlad
              Votes:
              3 Vote for this issue
              Watchers:
              9 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: