Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14898

MsBuild windows style environment variables no longer work

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • msbuild-plugin
    • None
    • Windows 7, XP

    Description

      After upgrading to version 1.15 of MSbuild plugin (from 1.13), it appears that dos style environment variables no longer work in the MSBuild arguments.

      Unix style environment variables do appear to work, and provide a workaround.

      For example, the following does not work:
      MSBuild Build File: %Project%\proj.sln
      but this does:
      MSBuild Build File: ${Project}\proj.sln

      I'm not sure if the change was intentional, but if it was, the help pop-ups are incorrect as they say the arguments should be the same as if you were to run MSBuild from the command line. Regardless of the intent, it would probably be good to have an environment variable in the help pop-up example.

      Attachments

        Activity

          anwallen Andrew Wallen created issue -
          ejschuiteman ejschuiteman made changes -
          Field Original Value New Value
          Priority Minor [ 4 ] Major [ 3 ]
          gbois Gregory Boissinot made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 145599 ] JNJira + In-Review [ 191556 ]

          People

            kdsweeney kdsweeney
            anwallen Andrew Wallen
            Votes:
            4 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: