Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15025

Maven-Tycho 0.15.0 build - no additional info in console log about compilation failure

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      When using Jenkins together with Maven and Tycho 0.13.0 version, in the console output of a build one can see detailed information about the exact cause of a compilation failure. Since upgrading to Tycho 0.15.0, when having a compilation failure, no additional info is shown in the console output. When running Maven and Tycho outside of Jenkins from command line, exact information about the compilation failure is shown and available.

      The current console output from Jenkins in case of a compilation failure looks like:
      message : Failed to execute goal org.eclipse.tycho:tycho-compiler-plugin:0.15.0:compile (default-compile) on project com.xxx: Compilation failure
      cause : Compilation failure
      Stack trace :
      org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.eclipse.tycho:tycho-compiler-plugin:0.15.0:compile (default-compile) on project com.xxx: Compilation failure
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:213)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
      at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
      at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
      at org.jvnet.hudson.maven3.launcher.Maven3Launcher.main(Maven3Launcher.java:79)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Launcher.java:329)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:239)
      at org.jvnet.hudson.maven3.agent.Maven3Main.launch(Maven3Main.java:158)
      at hudson.maven.Maven3Builder.call(Maven3Builder.java:98)
      at hudson.maven.Maven3Builder.call(Maven3Builder.java:64)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:287)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: copied.org.apache.maven.plugin.CompilationFailureException: Compilation failure
      at copied.org.apache.maven.plugin.AbstractCompilerMojo.execute(AbstractCompilerMojo.java:418)
      at org.eclipse.tycho.compiler.AbstractOsgiCompilerMojo.execute(AbstractOsgiCompilerMojo.java:179)
      at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
      ... 27 more
      channel stopped

      And that is all. No one could find out of that what is the real issue behind. Running Maven, Tycho again from the console to see the exact cause is quite troublesome.

        Attachments

          Issue Links

            Activity

            chris_mh3 chris_mh3 added a comment -

            If you run the build with the -X option compiler output is shown as [DEBUG] message. This should clearly be [ERROR].

            mythenmetz Andreas Bellmann added a comment -

            Hi everyone. I need this bug/feature so much that I'm willing to pay 10.00 bucks for it.
            This offer is registered at FreedomSponsors (http://www.freedomsponsors.org/core/issue/193/maven-tycho-0150-build-no-additional-info-in-console-log-about-compilation-failure).
            Once you solve it (according to the acceptance criteria described there), just create a FreedomSponsors account and mark it as resolved (oh, you'll need a Paypal account too)
            I'll then check it out and will gladly pay up!

            If anyone else would like to throw in a few bucks to elevate the priority on this issue, you should check out FreedomSponsors!

            nfalco79 Nikolas Falco added a comment -

            Me too.
            The same problem is restricted to job of type Maven2/3. With a job of kind general and a "Maven build" step there is no problem.

            Reason is the different handle of Maven execution and its exception in the MavenExecutionResult object. In a job of kind general is demand to Maven executable (Embedded Maven) instead in a job of kind Maven2/3 was reimplemented by jenkins to parse informations about sub-modules.

            I propose a solution with this pull request https://github.com/jenkinsci/jenkins/pull/851

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Nikolas Falco
            Path:
            maven-plugin/src/main/java/hudson/maven/Maven3Builder.java
            maven-plugin/src/main/java/hudson/maven/util/ExecutionEventLogger.java
            http://jenkins-ci.org/commit/jenkins/0b795de97e0aab2dda1af9b0ca7555cfd94a67b0
            Log:
            JENKINS-15025 Handle exceptions in the MavenExecutionResult in similar
            way as MavenCli do.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Nikolas Falco
            Path:
            maven-plugin/src/main/java/hudson/maven/Maven3Builder.java
            http://jenkins-ci.org/commit/jenkins/588e9cb7e122bda1e2aa2453fa99b8d4a94f418c
            Log:
            JENKINS-15025 Change PrintStreamLogger to System.out instead
            listener.getLogger (as MavenCli). In this manner output is highlighted.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Nikolas Falco
            Path:
            maven-plugin/src/main/java/hudson/maven/Maven3Builder.java
            maven-plugin/src/main/java/hudson/maven/util/ExecutionEventLogger.java
            http://jenkins-ci.org/commit/jenkins/361071d611c21758bf8e98a876599831a98d59c2
            Log:
            Merge branch 'JENKINS-15025'

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Kohsuke Kawaguchi
            Path:
            changelog.html
            maven-plugin/src/main/java/hudson/maven/Maven3Builder.java
            maven-plugin/src/main/java/hudson/maven/util/ExecutionEventLogger.java
            http://jenkins-ci.org/commit/jenkins/6af9127409255332c64ad1dd503f1ed24297f37a
            Log:
            [FIXED JENKINS-15025] no additional info in console log about failures

            Conflicts:
            maven-plugin/src/main/java/hudson/maven/Maven3Builder.java

            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #2758

            Result = SUCCESS

            nfalco Nikolas Falco added a comment -

            Merging pull request to master where there are commits for "Maven 3.1.0 support branch" brokes the fix.

            malamut Wolfgang Kronberg added a comment -

            Maven Release output is affected by this issue as well. For example, from the following original Maven output, all lines with a leading [ERROR] are removed in Jenkins console. Of course, this makes it impossible to find the original cause of the problem.

            ...
            [INFO] Checking dependencies and plugins for snapshots ...
            [INFO] ------------------------------------------------------------------------
            [INFO] BUILD FAILURE
            [INFO] ------------------------------------------------------------------------
            [INFO] Total time: 1.466s
            [INFO] Finished at: Mon Sep 16 13:06:28 CEST 2013
            [INFO] Final Memory: 13M/454M
            [INFO] ------------------------------------------------------------------------
            [ERROR] Failed to execute goal org.apache.maven.plugins:maven-release-plugin:2.1:prepare (default-cli) on project ********: Can't release project due to non released dependencies :
            [ERROR] ********-SNAPSHOT:compile
            [ERROR] in project ********
            [ERROR] -> [Help 1]
            [ERROR]
            [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
            [ERROR] Re-run Maven using the -X switch to enable full debug logging.
            [ERROR]
            [ERROR] For more information about the errors and possible solutions, please read the following articles:
            [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Nikolas Falco
            Path:
            src/main/java/hudson/maven/Maven3Builder.java
            src/main/java/hudson/maven/util/ExecutionEventLogger.java
            http://jenkins-ci.org/commit/maven-plugin/ba7c72982a9eeeeb90d1d03251c0ef17aad1b97d
            Log:
            JENKINS-15025 Handle exceptions in the MavenExecutionResult in similar
            way as MavenCli do.
            Originally-Committed-As: 0b795de97e0aab2dda1af9b0ca7555cfd94a67b0

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Nikolas Falco
            Path:
            src/main/java/hudson/maven/Maven3Builder.java
            http://jenkins-ci.org/commit/maven-plugin/9540dac9e3ffae15971e1883fa7afaf646e744a9
            Log:
            JENKINS-15025 Change PrintStreamLogger to System.out instead
            listener.getLogger (as MavenCli). In this manner output is highlighted.
            Originally-Committed-As: 588e9cb7e122bda1e2aa2453fa99b8d4a94f418c

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Nikolas Falco
            Path:
            src/main/java/hudson/maven/Maven3Builder.java
            src/main/java/hudson/maven/util/ExecutionEventLogger.java
            http://jenkins-ci.org/commit/maven-plugin/d18f0c37dc8c79865cf50041723e51c8376c00b9
            Log:
            Merge branch 'JENKINS-15025'
            Originally-Committed-As: 361071d611c21758bf8e98a876599831a98d59c2

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Kohsuke Kawaguchi
            Path:
            src/main/java/hudson/maven/Maven3Builder.java
            src/main/java/hudson/maven/util/ExecutionEventLogger.java
            http://jenkins-ci.org/commit/maven-plugin/19c4a4a0e9df8e2788703b44c84187b224ae239d
            Log:
            [FIXED JENKINS-15025] no additional info in console log about failures

            Conflicts:
            maven-plugin/src/main/java/hudson/maven/Maven3Builder.java

            Originally-Committed-As: 6af9127409255332c64ad1dd503f1ed24297f37a

            kutzi kutzi added a comment -

            Is most likely causing JENKINS-19352

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Christoph Kutzinski
            Path:
            src/main/java/hudson/maven/Maven3Builder.java
            http://jenkins-ci.org/commit/maven-plugin/53987d1c00d14dee7ab726b2eb7500f4f8b27599
            Log:
            JENKINS-19352: partial revert of JENKINS-15025, so that Maven exceptions are
            visible in the console log, again

            Compare: https://github.com/jenkinsci/maven-plugin/compare/c87013d3f82b...53987d1c00d1

            nfalco Nikolas Falco added a comment -

            Found the cause of problem in the merge.
            In the branch "Maven 3.1.0 support branch" was replace local instance of hudson.maven.util.ExecutionEventLogger with org.apache.maven.cli.event.ExecutionEventLogger in the MavenExecutionListener class.

            This cut off also a minor changes in the local ExecutionEventLogger where an Olivier Lamy note mention "copied from package org.apache.maven.cli with just one minor adaption for Maven3Mojo".

            I plan to:

            • move error processing (postponed by Maven3Launcher.main call) to a common place into the executor Maven3Builder class, this will work fine in case of Maven 3 (that use MavenExecutionListener) and with Maven 3.1 (that use JenkinsEventSpy class);
            • hudson.maven.util.ExecutionEventLogger extends (instead copy paste) original class, and override only method mojoStarted (more flexible to future changes);
            • restore use of hudson.maven.util.ExecutionEventLogger in the MavenExecutionListener class.
            nfalco Nikolas Falco added a comment -

            Maven job on a test project with compile errors. Running with Maven 3.1

            nfalco Nikolas Falco added a comment -

            Maven job on a test project with compile errors. Running with Maven 3.0. Summary is there but output is different due to slf4j settings.

            nfalco Nikolas Falco added a comment -
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Nikolas Falco
            Path:
            src/main/java/hudson/maven/Maven3Builder.java
            src/main/java/hudson/maven/util/ExecutionEventLogger.java
            http://jenkins-ci.org/commit/maven-plugin/8c008c588914c16f626b236d0bebe2073b9dacc5
            Log:
            [FIXED JENKINS-15025]: Maven-Tycho 0.15.0 build - no additional info in
            console log about compilation failure.

            Restore use of hudson.maven.util.ExecutionEventLogger in the
            MavenExecutionListener instance.
            Now it extends the original org.apache.maven.cli.ExecutionEventLogger
            and override only the enhanced mojoStarted method.
            Move the logic of errors processing to main executor class
            Maven3Builder.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Nikolas Falco
            Path:
            src/main/java/hudson/maven/Maven3Builder.java
            src/main/java/hudson/maven/Maven3ResultProcessor.java
            http://jenkins-ci.org/commit/maven-plugin/0cb01758f0379ec112e1e374871e598bfb41a7a5
            Log:
            [FIXED JENKINS-15025] Maven-Tycho 0.15.0 build - no additional info in
            console log about compilation failure

            Move Maven3ResultProcessor to external class
            CQI - change failNever variable name
            CQI - change return type of process method to boolean instead of int
            (default for CLI)
            Bug fix on compare project

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Nikolas Falco
            Path:
            src/main/java/hudson/maven/Maven3Builder.java
            src/main/java/hudson/maven/Maven3FailureLogger.java
            src/main/java/hudson/maven/Maven3ResultProcessor.java
            http://jenkins-ci.org/commit/maven-plugin/721e379ca4e0c7373d348c789b70eeb21a881cb6
            Log:
            [FIXED JENKINS-15025] Maven-Tycho 0.15.0 build - no additional info in console log about compilation failure

            Rename Maven3ResultProcessor to Maven3FailureLogger and move to package visibility.
            Method processFailure (now logFailures) only logs failure details, restore
            execution result check in Maven3Builder.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Nikolas Falco
            Path:
            src/main/java/hudson/maven/Maven3Builder.java
            src/main/java/hudson/maven/Maven3FailureLogger.java
            http://jenkins-ci.org/commit/maven-plugin/3f448208ec48828779d0c1f512dcc4e589d8c552
            Log:
            [FIXED JENKINS-15025] Maven-Tycho 0.15.0 build - no additional info in
            console log about compilation failure

            Rename method processCLIArguments to setOptions

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Christoph Kutzinski
            Path:
            src/main/java/hudson/maven/Maven3Builder.java
            src/main/java/hudson/maven/Maven3FailureLogger.java
            src/main/java/hudson/maven/util/ExecutionEventLogger.java
            http://jenkins-ci.org/commit/maven-plugin/b38d81d66de5d86ad70187740efd813ed2dd357b
            Log:
            Merge branch 'JENKINS-15025' of https://github.com/nfalco79/maven-plugin


              People

              Assignee:
              nfalco79 Nikolas Falco
              Reporter:
              katalin_boros Katalin Boros
              Votes:
              13 Vote for this issue
              Watchers:
              15 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: