Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1661

Read maven settings.xml from $M2_HOME/conf, too

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Maven reads its settings from either of two places.

      From http://maven.apache.org/settings.html :

      "There are two locations where a settings.xml file may live:

      The Maven install: $M2_HOME/conf/settings.xml
      A user's install: ${user.home}/.m2/settings.xml"

      Hudson, however, reads only the user specific settings and ignores the site-wide
      settings.

      It would be more consistent if hudson did exactly the same as maven:

      It should read $M2_HOME/conf/settings.xml if ${user.home}/.m2/settings.xml can't
      be found.

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -

            The main problem is that Hudson has its own Maven jars and it doesn't use your
            local Maven installation. IOW, it doesn't have "$M2_HOME".

            Perhaps we can try to load the one from Maven that you configured in the job.

            kohsuke Kohsuke Kawaguchi added a comment -

            Closing as a duplicate of #1088, as that one has higher vote counts.

                • This issue has been marked as a duplicate of 1088 ***

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              hok hok
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: