Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16923

Upgrade from 1.480.2 to 1.480.3 lost most of my jobs

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Duplicate
    • analysis-core-plugin
    • None

    Description

      I just upgraded from 1.480.2 to 1.480.3 and most of my jobs disappeared. Switching back to 1.480.2 brings all of my jobs back.

      I see the following errors in my stdout log file:

      Feb 20, 2013 10:05:03 PM hudson.model.Queue load
      WARNING: Failed to load the queue file /home/hudson/.hudson/queue.xml
      hudson.util.IOException2: Unable to read /home/hudson/.hudson/queue.xml
      at hudson.XmlFile.read(XmlFile.java:141)
      at hudson.model.Queue.load(Queue.java:333)
      at hudson.model.Queue.init(Queue.java:1848)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
      at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184
      )
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:882)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: com.thoughtworks.xstream.converters.ConversionException: No such job exists: fll-sw-feature-branches : No such job exists: fll-sw-feature-branches
      ---- Debugging information ----
      message : No such job exists: fll-sw-feature-branches
      cause-exception : java.util.NoSuchElementException
      cause-message : No such job exists: fll-sw-feature-branches
      class : java.util.ArrayList
      required-type : hudson.model.FreeStyleProject
      path : /list/hudson.model.Queue$BuildableItem/task
      line number : 20
      -------------------------------
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:89)
      at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
      at hudson.util.RobustReflectionConverter.unmarshalField(RobustReflectionConverter.java:292)
      at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:234)
      at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:181)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
      at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
      at com.thoughtworks.xstream.converters.collections.AbstractCollectionConverter.readItem(AbstractCollectionConverter.java:71)
      at hudson.util.RobustCollectionConverter.populateCollection(RobustCollectionConverter.java:85)
      at com.thoughtworks.xstream.converters.collections.CollectionConverter.unmarshal(CollectionConverter.java:61)
      at hudson.util.RobustCollectionConverter.unmarshal(RobustCollectionConverter.java:76)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
      at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:137)
      at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:33)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:926)
      at hudson.util.XStream2.unmarshal(XStream2.java:93)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:912)
      at com.thoughtworks.xstream.XStream.fromXML(XStream.java:864)
      at hudson.XmlFile.read(XmlFile.java:137)
      ... 15 more
      Caused by: java.util.NoSuchElementException: No such job exists: fll-sw-feature-branches
      at hudson.model.Queue$2.fromString(Queue.java:1685)
      at com.thoughtworks.xstream.converters.SingleValueConverterWrapper.fromString(SingleValueConverterWrapper.java:41)
      at com.thoughtworks.xstream.converters.SingleValueConverterWrapper.unmarshal(SingleValueConverterWrapper.java:49)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
      ... 39 more

      Attachments

        Issue Links

          Activity

            jpschewe jpschewe added a comment -

            I upgraded all plugins and the core at the same time and now I see all of my jobs.

            jpschewe jpschewe added a comment - I upgraded all plugins and the core at the same time and now I see all of my jobs.
            drulli Ulli Hafner added a comment -

            Ok, thanks. Then this really looks like JENKINS-12124.

            drulli Ulli Hafner added a comment - Ok, thanks. Then this really looks like JENKINS-12124 .
            jpschewe jpschewe added a comment -

            I only upgraded the core, not the plugins. I didn't try this again as I didn't have time to have a broken Jenkins for long, so I just reverted.

            jpschewe jpschewe added a comment - I only upgraded the core, not the plugins. I didn't try this again as I didn't have time to have a broken Jenkins for long, so I just reverted.
            drulli Ulli Hafner added a comment - - edited

            Did you also upgrade any plug-ins? This looks like a class loading problem in core.

            Is this error always reproducible, or happens just sometimes on startup?

            drulli Ulli Hafner added a comment - - edited Did you also upgrade any plug-ins? This looks like a class loading problem in core. Is this error always reproducible, or happens just sometimes on startup?
            jpschewe jpschewe added a comment -

            Yep, I went back farther in the log. This is the first non-info message after restarting with 1.480.3.

            EVERE: Failed Loading job geodesy-cpp
            java.lang.NoClassDefFoundError: hudson/plugins/analysis/core/AbstractProjectAction
            at java.lang.ClassLoader.defineClass1(Native Method)
            at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
            at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
            at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
            at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
            at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
            at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
            at hudson.plugins.warnings.WarningsPublisher.getProjectActions(WarningsPublisher.java:252)
            at hudson.model.Project.createTransientActions(Project.java:213)
            at hudson.model.AbstractProject.updateTransientActions(AbstractProject.java:658)
            at hudson.model.AbstractProject.onLoad(AbstractProject.java:292)
            at hudson.model.Project.onLoad(Project.java:88)
            at hudson.model.Items.load(Items.java:209)
            at jenkins.model.Jenkins$17.run(Jenkins.java:2516)
            at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
            at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
            at jenkins.model.Jenkins$7.runTask(Jenkins.java:882)
            at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
            at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
            at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
            at java.lang.Thread.run(Thread.java:662)
            Caused by: java.lang.ClassNotFoundException: hudson.plugins.analysis.core.AbstractProjectAction
            at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
            ... 26 more
            Feb 20, 2013 10:04:43 PM jenkins.InitReactorRunner$1 onTaskFailed

            jpschewe jpschewe added a comment - Yep, I went back farther in the log. This is the first non-info message after restarting with 1.480.3. EVERE: Failed Loading job geodesy-cpp java.lang.NoClassDefFoundError: hudson/plugins/analysis/core/AbstractProjectAction at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631) at java.lang.ClassLoader.defineClass(ClassLoader.java:615) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) at java.net.URLClassLoader.defineClass(URLClassLoader.java:283) at java.net.URLClassLoader.access$000(URLClassLoader.java:58) at java.net.URLClassLoader$1.run(URLClassLoader.java:197) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:306) at java.lang.ClassLoader.loadClass(ClassLoader.java:247) at hudson.plugins.warnings.WarningsPublisher.getProjectActions(WarningsPublisher.java:252) at hudson.model.Project.createTransientActions(Project.java:213) at hudson.model.AbstractProject.updateTransientActions(AbstractProject.java:658) at hudson.model.AbstractProject.onLoad(AbstractProject.java:292) at hudson.model.Project.onLoad(Project.java:88) at hudson.model.Items.load(Items.java:209) at jenkins.model.Jenkins$17.run(Jenkins.java:2516) at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146) at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259) at jenkins.model.Jenkins$7.runTask(Jenkins.java:882) at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187) at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) at java.lang.Thread.run(Thread.java:662) Caused by: java.lang.ClassNotFoundException: hudson.plugins.analysis.core.AbstractProjectAction at java.net.URLClassLoader$1.run(URLClassLoader.java:202) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:306) at java.lang.ClassLoader.loadClass(ClassLoader.java:247) ... 26 more Feb 20, 2013 10:04:43 PM jenkins.InitReactorRunner$1 onTaskFailed
            jglick Jesse Glick added a comment -

            The mentioned error looks like a symptom, not the cause; maybe there is something earlier in your log? Could be a plugin-specific issue, especially if some jobs loaded while others did not.

            jglick Jesse Glick added a comment - The mentioned error looks like a symptom, not the cause; maybe there is something earlier in your log? Could be a plugin-specific issue, especially if some jobs loaded while others did not.

            People

              drulli Ulli Hafner
              jpschewe jpschewe
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: