Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1822

Maven phase 'process-test-classes' is not invoked in m2 job

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      A new lifecycle phase 'process-test-classes' was introduced in maven-2.0.5, but hudson doesn't trigger
      the plugin goals associated with the phase, even when it is running on newer version of maven.
      I attached the test-harness pom.xml and it outputs 'process-test-classes phase was invoked.' on stand-
      alone maven, while it doesn't show up in hudson log.
      I believe it is caused by the fact that Hudson embeds maven-2.0.4, and components.xml used to inject
      interceptors remained old and doesn't contain the newly added phase.
      What is the strategy when Hudson needs to handle different version of maven with different
      components.xml definitions?
      Confirmed with build 1.218.

        Attachments

          Issue Links

            Activity

            jgyat jgyat added a comment -

            This issue is a duplicate of issue #2226

            k2nakamura k2nakamura added a comment -

            Created an attachment (id=278)
            test-harness


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              k2nakamura k2nakamura
              Votes:
              3 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: