Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18621

Weird IllegalArgumentException prevents SVN polling from working

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core, maven-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.517
    • Similar Issues:

      Description

      My job stopped to poll changes from SVN some time ago - it all runs properly when started manually or by timer, but it won't poll when a change occurs in repository. I have tried tweaking with Maven installations, cloning the job etc. Other jobs using Git do not have this problem. SVN polling shows:

      ERROR: Failed to record SCM polling for hudson.maven.MavenModuleSet@eafaabe[scmTest]
      java.lang.IllegalArgumentException: Null value not allowed as an environment variable: M2_HOME
      at hudson.EnvVars.put(EnvVars.java:172)
      at hudson.tasks.Maven$MavenInstallation.buildEnvVars(Maven.java:492)
      at hudson.maven.MavenModuleSetBuild.getEnvironment(MavenModuleSetBuild.java:173)
      at hudson.scm.SubversionSCM.compareRemoteRevisionWith(SubversionSCM.java:1230)
      at hudson.scm.SCM._compareRemoteRevisionWith(SCM.java:356)
      at hudson.scm.SCM.poll(SCM.java:373)
      at hudson.model.AbstractProject._poll(AbstractProject.java:1523)
      at hudson.model.AbstractProject.poll(AbstractProject.java:1448)
      at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:439)
      at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:468)
      at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:722)

      When I get into job configuration in Maven build section I get "ERROR" below Root POM line. I am attaching the exact ERROR message as a separate file.

        Attachments

        1. build.txt
          5 kB
        2. ERROR.txt
          8 kB

          Issue Links

            Activity

            pawelg Pawel Gronkiewicz created issue -
            pawelg Pawel Gronkiewicz made changes -
            Field Original Value New Value
            Attachment build.txt [ 23843 ]
            vlatombe Vincent Latombe made changes -
            Component/s pollscm [ 17336 ]
            pawelg Pawel Gronkiewicz made changes -
            Fix Version/s current [ 10162 ]
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            kutzi kutzi made changes -
            Link This issue duplicates JENKINS-18898 [ JENKINS-18898 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 149931 ] JNJira + In-Review [ 193357 ]

              People

              Assignee:
              vlatombe Vincent Latombe
              Reporter:
              pawelg Pawel Gronkiewicz
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: