Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1867

Allow users to be deleted

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Critical
    • Resolution: Fixed
    • core
    • None
    • Platform: All, OS: All

    Description

      There seems to be no possibility to delete a hudson user in the "manage user"
      part of the hudson user interface.

      I'm using the matrix based settings and have set for my account all checkboxes
      to selected. The account which I want to delete is a test user with no rights on
      the hudson system. However, there are no links or icons to execute this operation.

      Attachments

        Issue Links

          Activity

            It's a missing feature. Changed title accordingly.

            kohsuke Kohsuke Kawaguchi added a comment - It's a missing feature. Changed title accordingly.
            jiai jiai added a comment -

            Is there a current workaround? Is it possible to delete user directories when
            logged on to the host? Or are there other informations which must be deleted
            elsewhere?

            jiai jiai added a comment - Is there a current workaround? Is it possible to delete user directories when logged on to the host? Or are there other informations which must be deleted elsewhere?

            A work around is to delete the corresponding directory from $HUDSON_HOME/users/NAME

            kohsuke Kohsuke Kawaguchi added a comment - A work around is to delete the corresponding directory from $HUDSON_HOME/users/NAME
            mindless Alan Harder added a comment -
                • Issue 4786 has been marked as a duplicate of this issue. ***
            mindless Alan Harder added a comment - Issue 4786 has been marked as a duplicate of this issue. ***
            wohauser wohauser added a comment -

            Added myself to CC

            wohauser wohauser added a comment - Added myself to CC
            mindless Alan Harder added a comment -

            started

            mindless Alan Harder added a comment - started

            Code changed in hudson
            User: : mindless
            Path:
            trunk/hudson/main/core/src/main/java/hudson/model/User.java
            trunk/hudson/main/core/src/main/resources/hudson/model/User/delete.jelly
            trunk/hudson/main/core/src/main/resources/hudson/model/User/sidepanel.jelly
            trunk/hudson/main/core/src/main/resources/hudson/security/HudsonPrivateSecurityRealm/index.jelly
            trunk/www/changelog.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=24009
            Log:
            [FIXED JENKINS-1867] Add ability to delete users from Hudson

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : mindless Path: trunk/hudson/main/core/src/main/java/hudson/model/User.java trunk/hudson/main/core/src/main/resources/hudson/model/User/delete.jelly trunk/hudson/main/core/src/main/resources/hudson/model/User/sidepanel.jelly trunk/hudson/main/core/src/main/resources/hudson/security/HudsonPrivateSecurityRealm/index.jelly trunk/www/changelog.html http://fisheye4.cenqua.com/changelog/hudson/?cs=24009 Log: [FIXED JENKINS-1867] Add ability to delete users from Hudson

            People

              mindless Alan Harder
              jiai jiai
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: