Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19045

No page found 'digest.jelly'

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Not A Defect
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      javax.servlet.ServletException: org.apache.commons.jelly.JellyTagException: vfs:/content/jenkins.war/WEB-INF/lib/jenkins-core-1.525.jar/hudson/model/AbstractBuild/index.jelly:67:61: <st:include> No page found 'digest.jelly' for class hudson.maven.MavenModuleSetBuild
      at org.kohsuke.stapler.jelly.JellyClassTearOff.serveIndexJelly(JellyClassTearOff.java:117)
      at org.kohsuke.stapler.jelly.JellyFacet.handleIndexRequest(JellyFacet.java:127)
      at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:673)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:777)
      at org.kohsuke.stapler.MetaClass$12.dispatch(MetaClass.java:381)
      at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:684)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:777)

        Attachments

          Issue Links

            Activity

            ndeloof Nicolas De Loof added a comment -

            This actually is already the case, based on hudson.ClassicPluginStrategy#DETACHED_LIST
            BUT such (implicit) plugin dependecy is set as optional, and user can disable them without a warning. This breaks git-plugin when mailer plugin is disabled, but no way to fix afaik until git-plugin uses recent jenkins as base - something I want to avoid as MANY users are still running pretty old jenkins instances (even < 1.480).

            Would make sense anyway to make mailer dependency conditional in git-plugin, checking for hudson.task.Mailer class to be available in classpath.

            dmccreary Dan McCreary added a comment -

            Hello,

            I am a bit new to Jenkins, so my apologies if this comment is not appropriate. I have been working on the "digest.jelly" error for about day now and I don't seem to be getting any closer to finding a fix.

            I started getting this error when I upgraded Jenkins. I have now reinstalled it several times on versions going back to 1.515 from 19-May-2013. Yet I am still getting the same digest.jelly error. The comments here imply that the error is caused by a dependency in a plugin. So I have tried to install several of them, but without any results.

            Does anyone have any workaround?

            I am using Windows 7 with 16GB RAM and a doing a build from subversion repository. I have also tested on a Mac and get the same errors.

            Any help would be appreciated.

            Thanks! - Dan

            Error message is below:

            Exception: org.apache.commons.jelly.JellyTagException: jar:file:/D:/Apps/tomcat/orbeon4.3/webapps/jenkins/WEB-INF/lib/jenkins-core-1.515.jar!/hudson/model/AbstractBuild/index.jelly:67:61: <st:include> No page found 'digest.jelly' for class hudson.model.FreeStyleBuild
            Stacktrace:
            javax.servlet.ServletException: org.apache.commons.jelly.JellyTagException: jar:file:/D:/Apps/tomcat/orbeon4.3/webapps/jenkins/WEB-INF/lib/jenkins-core-1.515.jar!/hudson/model/AbstractBuild/index.jelly:67:61: <st:include> No page found 'digest.jelly' for class hudson.model.FreeStyleBuild
            at org.kohsuke.stapler.jelly.JellyClassTearOff.serveIndexJelly(JellyClassTearOff.java:117)
            at org.kohsuke.stapler.jelly.JellyFacet.handleIndexRequest(JellyFacet.java:127)

            rstoll Robert Stoll added a comment -

            In my case the plugins were installed but not activated. You might want to check this. Hope that helps.
            Cheers, Robert

            dmccreary Dan McCreary added a comment -

            Thanks Robert!

            I tried this but it did not work.

            I did find that if I use the separate Windows and Mac installer and not the war file install on an existing Tomcat that the problem goes away. This is only a short-term fix for some urgent work, but running two web servers is not a good long-term solution.

            I am willing to pay someone to fix this or trade consulting services. Anyone need an XML guru?

            • Dan
            danielbeck Daniel Beck added a comment -

            Issue caused by invalid plugin configuration. not a bug.

            Jenkins should really tell you if your plugin configuration is potentially invalid (it's easier to determine with mandatory dependencies than with implied ones) – filed JENKINS-23150 to track improvements in that area.


              People

              Assignee:
              ndeloof Nicolas De Loof
              Reporter:
              hsn Radim Kolar
              Votes:
              4 Vote for this issue
              Watchers:
              10 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: