Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1914

parameterized builds

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: other
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      already partially implemented - submitting issue to track svn commits

      r9927 Initial commit of parameterized builds. Provided functionality:

      • users can define parameters per project (only string paramters for now)
      • if a project has parameters, the 'build' button will redirect to an input page
      • parameter values can be used as ${variable} in Ant, Maven and
        CommandInterpreter builders
      • after the build, parameter values can be viewed in a separate page
      • tasks for parameterized builds are persisted in the queue over restarts
      • queue persistence is now in XML (with backwards compatibility for text format)

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : huybrechts
            Path:
            branches/tom/main/core/src/main/java/hudson/model/JobParameterDefinition.java
            branches/tom/main/core/src/main/java/hudson/model/JobParameterValue.java
            branches/tom/main/core/src/main/java/hudson/model/ParametersAction.java
            branches/tom/main/core/src/main/java/hudson/model/ParametersDefinitionProperty.java
            branches/tom/main/core/src/main/java/hudson/model/Queue.java
            branches/tom/main/core/src/main/java/hudson/model/RunParameterDefinition.java
            branches/tom/main/core/src/main/java/hudson/model/RunParameterValue.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=10334
            Log:
            JENKINS-1914 additional parameter types (job, run), bugfixes

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/www/changelog.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=10994
            Log:
            [FIXED JENKINS-1573 JENKINS-1915 JENKINS-1504 JENKINS-1914]
            Noting the changes merged into the trunk in Hudson 1.237.

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 1565 has been marked as a duplicate of this issue. ***
            canhuth canhuth added a comment -

            It could be useful to have the same functionality in the Batch Task plugin.

            kohsuke Kohsuke Kawaguchi added a comment -

            Should be marked as fixed already since it's integrated.

            mdonohue mdonohue added a comment -
                • Issue 56 has been marked as a duplicate of this issue. ***

              People

              Assignee:
              huybrechts huybrechts
              Reporter:
              huybrechts huybrechts
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: