Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2157

UnsupportedOperationException occurs when running jobs after updating to 1.240

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Duplicate
    • maven-plugin
    • None
    • Platform: All, OS: Linux

    Description

      I updated my hudson from 1.236 to 1.240. The hudson.war runs under jdk 1.6 in
      jboss 4.2 but the jobs execute under jdk jrockit-R27.5.0-jdk1.5.0_14.

      Since updating, all my jobs now fail with an UnsupportedOperationException.

      ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] null
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      java.lang.UnsupportedOperationException
      at java.util.Collections$UnmodifiableCollection.addAll(Collections.java:1028)
      at hudson.plugins.tasks.util.ParserResult.addModules(ParserResult.java:202)
      at hudson.plugins.tasks.TasksReporter.perform(TasksReporter.java:178)
      at hudson.plugins.tasks.TasksReporter.perform(TasksReporter.java:32)
      at
      hudson.plugins.tasks.util.HealthAwareMavenReporter.postExecute(HealthAwareMavenReporter.java:124)
      at
      hudson.maven.MavenModuleSetBuild$Builder.postExecute(MavenModuleSetBuild.java:597)
      at hudson.maven.MavenBuilder$Adapter.postExecute(MavenBuilder.java:256)
      at
      hudson.maven.agent.PluginManagerInterceptor$1MojoIntercepterImpl.callPost(PluginManagerInterceptor.java:147)
      at
      hudson.maven.agent.PluginManagerInterceptor.executeMojo(PluginManagerInterceptor.java:160)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:539)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:480)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:459)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:311)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:278)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:143)
      at
      org.apache.maven.lifecycle.LifecycleExecutorInterceptor.execute(LifecycleExecutorInterceptor.java:42)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:333)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:126)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:282)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at hudson.maven.agent.Main.launch(Main.java:133)
      at hudson.maven.MavenBuilder.call(MavenBuilder.java:135)
      at hudson.maven.MavenModuleSetBuild$Builder.call(MavenModuleSetBuild.java:536)
      at hudson.maven.MavenModuleSetBuild$Builder.call(MavenModuleSetBuild.java:482)
      at hudson.remoting.UserRequest.perform(UserRequest.java:69)
      at hudson.remoting.UserRequest.perform(UserRequest.java:23)
      at hudson.remoting.Request$2.run(Request.java:206)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
      at java.util.concurrent.FutureTask.run(FutureTask.java:123)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)

      Attachments

        Issue Links

          Activity

            jutter jutter created issue -
            francisdb francisdb added a comment -

            I'm having this issue since I updated the plugins

            francisdb francisdb added a comment - I'm having this issue since I updated the plugins
            francisdb francisdb added a comment -

            https://hudson.dev.java.net/issues/show_bug.cgi?id=2153

                • This issue has been marked as a duplicate of 2153 ***
            francisdb francisdb added a comment - https://hudson.dev.java.net/issues/show_bug.cgi?id=2153 This issue has been marked as a duplicate of 2153 ***
            francisdb francisdb made changes -
            Field Original Value New Value
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            francisdb francisdb made changes -
            Link This issue duplicates JENKINS-2153 [ JENKINS-2153 ]
            abayer Andrew Bayer made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            ircbot Jenkins IRC Bot made changes -
            Component/s maven-plugin [ 16033 ]
            Component/s maven2 [ 15487 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 132230 ] JNJira + In-Review [ 201250 ]

            People

              Unassigned Unassigned
              jutter jutter
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: