Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2179

NPE in Ant.perform()

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: ant-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:

      Description

      I was having the problems described at
      http://www.nabble.com/Builds-stay-in-pending-state-even-when-there-are-free-executors-td18496331.html
      while using 1.232-private (232 plus a couple of patches I submitted) and
      following what seemed to work for one of those users, I tried upgrading to latest.

      After stopping the server, replacing the .war with the 1.244 war, and restarting
      the server, my builds picked up out of the queue, but then failed like so...
      (from the console output)

      FATAL: null
      java.lang.NullPointerException
      at hudson.tasks.Ant.perform(Ant.java:124)
      at hudson.model.Build$RunnerImpl.build(Build.java:134)
      at hudson.model.Build$RunnerImpl.doRun(Build.java:109)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:231)
      at hudson.model.Run.run(Run.java:786)
      at hudson.model.Build.run(Build.java:84)
      at hudson.model.ResourceController.execute(ResourceController.java:70)
      at hudson.model.Executor.run(Executor.java:88)

      This comes immediately after it finished updating from svn.

      java version "1.6.0_06"
      Java(TM) SE Runtime Environment (build 1.6.0_06-b02)

      running winstone, java service wrapper, on linux.

        Attachments

          Issue Links

            Activity

            karljp karljp added a comment -

            I downgraded to 1.237, and although the build queue was now empty, I got no NPEs
            when I manually triggered the builds again. (FWIW)

            I'll run 237 for a while, see if I run into the "waiting for next available
            executor" again.

            kohsuke Kohsuke Kawaguchi added a comment -

            A bug like this is really embarrassing.
            This is a dupe of issue #2177

                • This issue has been marked as a duplicate of 2177 ***

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              karljp karljp
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: