Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22095

Failed inspecting plugin: archive is not a ZIP archive

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Not A Defect
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      I see many of these errors in the log:

      Mar 07, 2014 8:32:51 PM SEVERE jenkins.InitReactorRunner$1 onTaskFailed
      Failed Inspecting plugin /var/lib/jenkins/plugins/ssh-slaves.jpi
      java.io.IOException: Failed to expand /var/lib/jenkins/plugins/ssh-slaves.jpi
      	at hudson.ClassicPluginStrategy.explode(ClassicPluginStrategy.java:429)
      	at hudson.ClassicPluginStrategy.createPluginWrapper(ClassicPluginStrategy.java:126)
      	at hudson.PluginManager$1$3$1.run(PluginManager.java:236)
      	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
      	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      	at jenkins.model.Jenkins$7.runTask(Jenkins.java:899)
      	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:701)
      Caused by: Error while expanding /var/lib/jenkins/plugins/ssh-slaves.jpi
      java.util.zip.ZipException: archive is not a ZIP archive
      	at org.apache.tools.ant.taskdefs.Expand.expandFile(Expand.java:192)
      	at org.apache.tools.ant.taskdefs.Expand.execute(Expand.java:132)
      	at hudson.ClassicPluginStrategy.unzipExceptClasses(ClassicPluginStrategy.java:501)
      	at hudson.ClassicPluginStrategy.explode(ClassicPluginStrategy.java:426)
      	... 10 more
      Caused by: java.util.zip.ZipException: archive is not a ZIP archive
      	at org.apache.tools.zip.ZipFile.positionAtCentralDirectory(ZipFile.java:481)
      	at org.apache.tools.zip.ZipFile.populateFromCentralDirectory(ZipFile.java:320)
      	at org.apache.tools.zip.ZipFile.<init>(ZipFile.java:186)
      	at org.apache.tools.ant.taskdefs.Expand.expandFile(Expand.java:170)
      	... 13 more

      As a result the plugins don't load. All their dependencies don't load too. No errors are displayed in the frontend which is extremely confusing.

        Attachments

          Issue Links

            Activity

            lzr gene lzr added a comment - - edited

            Looks like there's a firewall problem. All problematic jpi files are 205 bytes long:

             OK
            Server: Netscreen 100
            Connection: close
            Content-Length: 142
            Conent-Type: text/html
            
            <body>Zip file has been blocked by your firewall</body></html>

            However, this is an extremely bad way to handle an exception. If there's a firewall issue, I feel like Jenkins should warn about that, instead of saving broken jpi files.

            danielbeck Daniel Beck added a comment -

            Tell your firewall admin to not send 200 OK when there's nothing "OK" about that gets returned.

            Other than that, JENKINS-14616 and JENKINS-21485 already track related robustness + admin visibility issues.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              lzr gene lzr
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: