Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22189

Delivery Pipeline View only shows first component

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • None
    • Jenkins 1.538, Delivery Pipeline Plugin 0.7.0

    Description

      Since we deployed the Delivery Pileline Plugin 0.7.0 our delivery pipeline views are only showing the first defined component. We are using this view to show only the aggregated views of several components to see the current pipeline status of each component.

      Since 0.7.0 this is not longer possible for us.

      Attachments

        Activity

          Created release 0.7.1 which contains this fix.

          patbos Patrik Boström added a comment - Created release 0.7.1 which contains this fix.
          patbos Patrik Boström added a comment - Fixed in commit https://github.com/Diabol/delivery-pipeline-plugin/commit/c92b0c8bf55c159e1c7d145dcd9f6ba31f19822e
          patbos Patrik Boström added a comment - - edited

          The problem is in the javascript. It did not iterate properly over the array of components returned.

          patbos Patrik Boström added a comment - - edited The problem is in the javascript. It did not iterate properly over the array of components returned.

          People

            patbos Patrik Boström
            lask79 Lasse Knudsen
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: