Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2226

hudson ignores process-test-classes phase ( maven 2.0.5 +)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      maven 2.0.5 introduced this new phase, but hudson ignores it. Is it b/c Hudson
      uses maven 2.0.4 embedder??

      more on this is at http://www.nabble.com/hudson-ignores-process-test-classes-
      phase-%28-maven-2.0.5-%2B%29-to18824186.html#a18824186

        Attachments

          Issue Links

            Activity

            Hide
            jgyat jgyat added a comment -

            This issue is a duplicate of issue #1822

            Show
            jgyat jgyat added a comment - This issue is a duplicate of issue #1822
            Hide
            asimon_redhat asimon_redhat added a comment -

            Created an attachment (id=683)
            this components.xml that contains the missing step should be used in /maven-agent/src/main/resources/META-INF/plexus/ and maven-interceptor/src/main/resources/META-INF/plexus

            Show
            asimon_redhat asimon_redhat added a comment - Created an attachment (id=683) this components.xml that contains the missing step should be used in /maven-agent/src/main/resources/META-INF/plexus/ and maven-interceptor/src/main/resources/META-INF/plexus
            Hide
            slowstrider slowstrider added a comment -

            I am having exactly the same issue while using the OpenJPA enhancer on our test
            classes. I am using maven 2.0.10.

            Manually running the command "mvn clean install" works perfectly, but inside
            Hudson my tests fail because the enhancer wasn't called.

            Is there a workaround?

            Show
            slowstrider slowstrider added a comment - I am having exactly the same issue while using the OpenJPA enhancer on our test classes. I am using maven 2.0.10. Manually running the command "mvn clean install" works perfectly, but inside Hudson my tests fail because the enhancer wasn't called. Is there a workaround?
            Hide
            slowstrider slowstrider added a comment -

            Workaround that worked for my enhance goal: Change the phase from
            process-test-classes to test-compile.

            Use at your own risk; I am just starting out with Maven and I don't know if
            there are guarantees that your own goal is called after the test classes are
            compiled.

            Show
            slowstrider slowstrider added a comment - Workaround that worked for my enhance goal: Change the phase from process-test-classes to test-compile. Use at your own risk; I am just starting out with Maven and I don't know if there are guarantees that your own goal is called after the test classes are compiled.
            Hide
            asimon_redhat asimon_redhat added a comment -

            Can we apply the suggested fix to trunk?
            i.e.
            Add the missing step to
            /maven-agent/src/main/resources/META-INF/plexus/ and
            maven-interceptor/src/main/resources/META-INF/plexus
            Cheers

            Show
            asimon_redhat asimon_redhat added a comment - Can we apply the suggested fix to trunk? i.e. Add the missing step to /maven-agent/src/main/resources/META-INF/plexus/ and maven-interceptor/src/main/resources/META-INF/plexus Cheers
            Hide
            dleonard0 dleonard0 added a comment -

            process-test-classes is missing from both maven-agent/.../components.xml and
            maven-interceptor/...components.xml

            Show
            dleonard0 dleonard0 added a comment - process-test-classes is missing from both maven-agent/.../components.xml and maven-interceptor/...components.xml
            Hide
            abayer Andrew Bayer added a comment -

            This is, I believe, fixed if you use Maven 2.1 or later.

            Show
            abayer Andrew Bayer added a comment - This is, I believe, fixed if you use Maven 2.1 or later.
            Hide
            ALRubinger ALRubinger added a comment -

            Attached patch

            Show
            ALRubinger ALRubinger added a comment - Attached patch
            Hide
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : abayer
            Path:
            trunk/hudson/main/maven-interceptor/src/main/resources/META-INF/plexus/components.xml
            trunk/www/changelog.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=26090
            Log:
            [FIXED JENKINS-2226] Added process-test-classes phase

            Show
            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : abayer Path: trunk/hudson/main/maven-interceptor/src/main/resources/META-INF/plexus/components.xml trunk/www/changelog.html http://fisheye4.cenqua.com/changelog/hudson/?cs=26090 Log: [FIXED JENKINS-2226] Added process-test-classes phase

              People

              Assignee:
              abayer Andrew Bayer
              Reporter:
              danttran danttran
              Votes:
              4 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: