Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22654

Multi-configuration projects display with wrong Delivery Pipeline Stage Name

    XMLWordPrintable

Details

    Description

      Hi there – thanks for the Delivery Pipeline plugin!

      I've tried to set up a multi-config project with Delivery Pipeline 0.7.4; it mostly works correctly, but in the resulting pipeline visualization, the Stage Name I've specified is ignored, and instead the multi-configuration's "User Defined Axis" is used.

      Attachments

        Activity

          justinmason Justin Mason created issue -
          patbos Patrik Boström added a comment - - edited

          Hi,

          Can't reproduce the issue.
          I created a job A which is a freestyle one, a job B which is a multi-configuration job. A will trigger B. Configured stage and task names. When looking in the view the configured stage name and task name is used.

          patbos Patrik Boström added a comment - - edited Hi, Can't reproduce the issue. I created a job A which is a freestyle one, a job B which is a multi-configuration job. A will trigger B. Configured stage and task names. When looking in the view the configured stage name and task name is used.
          justinmason Justin Mason added a comment - - edited

          hi Patrik! Apologies for the delay, it looks like I managed to miss the mail when you responded

          I left out sufficient details to clarify this. Here's the exact process I followed to repro it:

          New Job
          TestMulti: multi-configuration
          Stage Name: stage2
          Add User-defined Axis
          Name: axis
          Values: foo bar

          New Job
          TestStart: free-style software project
          Stage Name: stage1
          Task Name: task
          Build other projects: TestMulti/axis=foo, TestMulti/axis=bar

          New View
          TestPipeline: Delivery Pipeline view
          Components: add
          Name: start
          Initial Job: TestStart

          click http://jenkins/job/TestStart/build?delay=0sec
          go to http://jenkins/view/TestPipeline/?

          What you see is the following: https://www.dropbox.com/s/uyzg86bh7wiqy0z/Screenshot%202014-07-10%2014.34.13.PNG . Note the two "stage2" jobs are in separate "Stage" blocks called "foo" and "bar".

          What we should see: is that the two "stage2" jobs appear in a single Stage block called "stage2".

          justinmason Justin Mason added a comment - - edited hi Patrik! Apologies for the delay, it looks like I managed to miss the mail when you responded I left out sufficient details to clarify this. Here's the exact process I followed to repro it: New Job TestMulti: multi-configuration Stage Name: stage2 Add User-defined Axis Name: axis Values: foo bar New Job TestStart: free-style software project Stage Name: stage1 Task Name: task Build other projects: TestMulti/axis=foo, TestMulti/axis=bar New View TestPipeline: Delivery Pipeline view Components: add Name: start Initial Job: TestStart click http://jenkins/job/TestStart/build?delay=0sec go to http://jenkins/view/TestPipeline/? What you see is the following: https://www.dropbox.com/s/uyzg86bh7wiqy0z/Screenshot%202014-07-10%2014.34.13.PNG . Note the two "stage2" jobs are in separate "Stage" blocks called "foo" and "bar". What we should see: is that the two "stage2" jobs appear in a single Stage block called "stage2".

          Thanks for the clarification!
          When I tried to reproduce I configured job TestStart to trigger downstream project TestMulti instead of the two axis.

          patbos Patrik Boström added a comment - Thanks for the clarification! When I tried to reproduce I configured job TestStart to trigger downstream project TestMulti instead of the two axis.
          justinmason Justin Mason added a comment -

          Yes – that seems to work ok, but does not allow differentiation between the axes.

          Our use case is to fan out from a build step to a set of deploy steps; deploy service X, service Y, service Z. Right now we just have a set of manually-duplicated, hand-edited jobs, but it'd be much cleaner if a multi-config build could be used, defining X, Y, Z as the values of the service_name axis. Being a continuous delivery pipeline, those deploy steps have a manual approval, so (for example) for a given build we could decide to push the button for "deploy X" and "deploy Z" only, hence building the top-level job (and allowing all sub-jobs to build as a result) wouldn't work for us.

          justinmason Justin Mason added a comment - Yes – that seems to work ok, but does not allow differentiation between the axes. Our use case is to fan out from a build step to a set of deploy steps; deploy service X, service Y, service Z. Right now we just have a set of manually-duplicated, hand-edited jobs, but it'd be much cleaner if a multi-config build could be used, defining X, Y, Z as the values of the service_name axis. Being a continuous delivery pipeline, those deploy steps have a manual approval, so (for example) for a given build we could decide to push the button for "deploy X" and "deploy Z" only, hence building the top-level job (and allowing all sub-jobs to build as a result) wouldn't work for us.

          Had a look at the issue. Is this a good solution for the above example?

          patbos Patrik Boström added a comment - Had a look at the issue. Is this a good solution for the above example?
          patbos Patrik Boström made changes -
          Field Original Value New Value
          Attachment JENKINS-22654-suggested-solution.png [ 26509 ]
          patbos Patrik Boström added a comment - Suggested fix is in this branch: https://github.com/Diabol/delivery-pipeline-plugin/tree/JENKINS-22654_multi_configuration_stage_task_names
          justinmason Justin Mason added a comment -

          Yes, looks great!

          justinmason Justin Mason added a comment - Yes, looks great!
          patbos Patrik Boström added a comment - Created PR https://github.com/Diabol/delivery-pipeline-plugin/pull/78

          Merged to master

          patbos Patrik Boström added a comment - Merged to master
          patbos Patrik Boström made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]

          Released in 0.8.5

          patbos Patrik Boström added a comment - Released in 0.8.5
          patbos Patrik Boström made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 154765 ] JNJira + In-Review [ 207624 ]

          People

            Unassigned Unassigned
            justinmason Justin Mason
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: