Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23267

NullPointerException in XvfbBuildWrapper.setUp when configured without node label restrictions

    XMLWordPrintable

Details

    Description

      I get the following traceback when running a job with configured xvfb plugin and no node labels:

      FATAL: null
      java.lang.NullPointerException
      at org.jenkinsci.plugins.xvfb.XvfbBuildWrapper.setUp(XvfbBuildWrapper.java:568)
      at hudson.model.Build$BuildExecution.doRun(Build.java:153)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:518)
      at hudson.model.Run.execute(Run.java:1706)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:231)

      The line reads:

      if (assignedLabels != null || assignedLabels.trim().isEmpty()) {

      shouldn't that be && ?

      A workaround is adding a label (i.e. master)

      Attachments

        Activity

          sk1p Alexander Clausen created issue -
          sk1p Alexander Clausen made changes -
          Field Original Value New Value
          Description I get the following traceback when running a job with configured xvfb plugin:

          FATAL: null
          java.lang.NullPointerException
          at org.jenkinsci.plugins.xvfb.XvfbBuildWrapper.setUp(XvfbBuildWrapper.java:568)
          at hudson.model.Build$BuildExecution.doRun(Build.java:153)
          at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:518)
          at hudson.model.Run.execute(Run.java:1706)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          at hudson.model.ResourceController.execute(ResourceController.java:88)
          at hudson.model.Executor.run(Executor.java:231)

          The line reads:

          if (assignedLabels != null || assignedLabels.trim().isEmpty()) {

          shouldn't that be && ?
          I get the following traceback when running a job with configured xvfb plugin and no node labels:

          FATAL: null
          java.lang.NullPointerException
          at org.jenkinsci.plugins.xvfb.XvfbBuildWrapper.setUp(XvfbBuildWrapper.java:568)
          at hudson.model.Build$BuildExecution.doRun(Build.java:153)
          at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:518)
          at hudson.model.Run.execute(Run.java:1706)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          at hudson.model.ResourceController.execute(ResourceController.java:88)
          at hudson.model.Executor.run(Executor.java:231)

          The line reads:

          if (assignedLabels != null || assignedLabels.trim().isEmpty()) {

          shouldn't that be && ?

          A workaround is adding a label (i.e. master)
          Summary NullPointerException in XvfbBuildWrapper.setUp NullPointerException in XvfbBuildWrapper.setUp when configured without node label restrictions
          zregvart zregvart made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          zregvart zregvart made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 155830 ] JNJira + In-Review [ 207751 ]

          People

            zregvart zregvart
            sk1p Alexander Clausen
            Votes:
            2 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: