Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23824

Stage connector arrows missing in version 0.8.2

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • Jenkins 1.571, Delivery Pipeline Plugin 0.8.2, Build Pipeline Plugin 1.4.3

    Description

      The dynamic JS arrows between stages no longer show up in version 0.8.2 in either Firefox or Chrome. The problem appears in fullscreen view and non-fullscreen. The arrows are absent when not using custom CSS.

      The arrows appear correctly in version 0.8.1 of the Delivery Pipeline Plugin.

      Attachments

        Activity

          craftsman Roy Miller created issue -

          Not able to reproduce it. But I made some changes in CSS with z-index for a couple of classes. Wonder if that could be the problem.

          patbos Patrik Boström added a comment - Not able to reproduce it. But I made some changes in CSS with z-index for a couple of classes. Wonder if that could be the problem.
          tduskin Trey Duskin added a comment -

          I have this issue in 0.8.3 as well. It showed up after I upgraded my Jenkins install to 1.574 which uses the new responsive styling. In my case, the arrows are there but they are floating out in space. See attached screenshot.

          tduskin Trey Duskin added a comment - I have this issue in 0.8.3 as well. It showed up after I upgraded my Jenkins install to 1.574 which uses the new responsive styling. In my case, the arrows are there but they are floating out in space. See attached screenshot.
          tduskin Trey Duskin added a comment -

          0.8.3 floating arrows

          tduskin Trey Duskin added a comment - 0.8.3 floating arrows
          tduskin Trey Duskin made changes -
          Field Original Value New Value
          Attachment Screen Shot 2014-08-04 at 2.45.28 PM.png [ 26482 ]
          craftsman Roy Miller added a comment -

          Odd that you can't reproduce it, Patrik. I'll poke around some more and see if I see what Trey does with 1.574, or if I can dig up more info to share to make this easier to track down.

          craftsman Roy Miller added a comment - Odd that you can't reproduce it, Patrik. I'll poke around some more and see if I see what Trey does with 1.574, or if I can dig up more info to share to make this easier to track down.
          patbos Patrik Boström made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          patbos Patrik Boström added a comment - - edited

          Managed to reproduce problem.
          Have created a fix (https://github.com/Diabol/delivery-pipeline-plugin/pull/75)

          Have attached a hpi with the fix.
          If you have the possibility to test the fix I would be really happy!

          patbos Patrik Boström added a comment - - edited Managed to reproduce problem. Have created a fix ( https://github.com/Diabol/delivery-pipeline-plugin/pull/75 ) Have attached a hpi with the fix. If you have the possibility to test the fix I would be really happy!
          patbos Patrik Boström made changes -
          Attachment delivery-pipeline-plugin.hpi [ 26483 ]
          patbos Patrik Boström made changes -
          Status In Progress [ 3 ] Open [ 1 ]
          patbos Patrik Boström made changes -
          Status Open [ 1 ] In Progress [ 3 ]

          Merged to master

          patbos Patrik Boström added a comment - Merged to master
          patbos Patrik Boström made changes -
          Status In Progress [ 3 ] Open [ 1 ]

          Released in 0.8.4

          patbos Patrik Boström added a comment - Released in 0.8.4
          patbos Patrik Boström made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          patbos Patrik Boström made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          craftsman Roy Miller added a comment -

          Sorry for the late response, Patrik. I got sidetracked with other things this week. I see you already released the fix, so I installed it this morning and I can confirm that you did indeed fix the problem.

          The stage connector arrows show up now, just like they used to. They don't show up in my modified stylesheet for some reason, so I'll have to change that, but they do show up in the default display.

          Well done!

          On a different note, I'd like to send you a private email. Should I use the email address linked to by your name in the comments here, or is there another address I should use? Feel free to email me privately at myfirstname dot mylastname at devellocus.com. Thanks.

          craftsman Roy Miller added a comment - Sorry for the late response, Patrik. I got sidetracked with other things this week. I see you already released the fix, so I installed it this morning and I can confirm that you did indeed fix the problem. The stage connector arrows show up now, just like they used to. They don't show up in my modified stylesheet for some reason, so I'll have to change that, but they do show up in the default display. Well done! On a different note, I'd like to send you a private email. Should I use the email address linked to by your name in the comments here, or is there another address I should use? Feel free to email me privately at myfirstname dot mylastname at devellocus.com. Thanks.
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 156615 ] JNJira + In-Review [ 207864 ]

          People

            patbos Patrik Boström
            craftsman Roy Miller
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: