Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24586

NPE in at alex.jenkins.plugins.FileSystemListParameterDefinition.createAllObjectsMap(FileSystemListParameterDefinition.java:342)

    XMLWordPrintable

Details

    Description

      Getting an NPE with this message:
      Caused by: java.lang.NullPointerException
      at alex.jenkins.plugins.FileSystemListParameterDefinition.createAllObjectsMap(FileSystemListParameterDefinition.java:342)
      at alex.jenkins.plugins.FileSystemListParameterDefinition.getFsObjectsList(FileSystemListParameterDefinition.java:210)

      Attachments

        Activity

          walterk82 Walter Kacynski created issue -
          walterk82 Walter Kacynski made changes -
          Field Original Value New Value
          Assignee Alexander Endter [ aendter ]
          danielbeck Daniel Beck added a comment -

          Jenkins generally allows you to enter invalid input and lets you suffer afterwards.

          In this case, because you did not enter a folder path despite the bold, red message telling you to.

          danielbeck Daniel Beck added a comment - Jenkins generally allows you to enter invalid input and lets you suffer afterwards. In this case, because you did not enter a folder path despite the bold, red message telling you to.
          danielbeck Daniel Beck made changes -
          Priority Major [ 3 ] Minor [ 4 ]

          Code changed in jenkins
          User: aendter
          Path:
          src/main/java/alex/jenkins/plugins/FileSystemListParameterDefinition.java
          src/main/resources/alex/jenkins/plugins/FileSystemListParameterDefinition/config.jelly
          http://jenkins-ci.org/commit/filesystem-list-parameter-plugin/caa8a608866537f86da4baf0bf642384409c84b8
          Log:
          JENKINS-24586
          avoid NPE

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: aendter Path: src/main/java/alex/jenkins/plugins/FileSystemListParameterDefinition.java src/main/resources/alex/jenkins/plugins/FileSystemListParameterDefinition/config.jelly http://jenkins-ci.org/commit/filesystem-list-parameter-plugin/caa8a608866537f86da4baf0bf642384409c84b8 Log: JENKINS-24586 avoid NPE
          aendter Alexander Endter made changes -
          Status Open [ 1 ] In Progress [ 3 ]

          Fixed in version 0.0.3

          aendter Alexander Endter added a comment - Fixed in version 0.0.3
          aendter Alexander Endter made changes -
          Resolution Fixed [ 1 ]
          Status In Progress [ 3 ] Resolved [ 5 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 157612 ] JNJira + In-Review [ 195762 ]

          People

            aendter Alexander Endter
            walterk82 Walter Kacynski
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: