Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24996

FitNesse plugin closes I/O stream unexpectedly when running tests after starting FitNesse itself

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Duplicate
    • fitnesse-plugin
    • None
    • Jenkins 1.583, FitNesse 20130530, Plugin-version 1.9
      All on OpenSuSE 13.1 with Oracle JDK 8

    Description

      When running FitNesse-tests from the Jenkins-plugin, I get the following in console-output:

      Starting new Fitnesse instance...
      [.] $ /usr/java/latest/bin/java -jar /var/lib/jenkins/jobs/Run-FitNesse-tests/workspace/fitnesse-standalone.jar -d /var/lib/jenkins/jobs/Run-FitNesse-tests/workspace -r root -p 7100
      FitNesse (v20130530) Started...
      port: 7100
      root page: fitnesse.wiki.FileSystemPage at /var/lib/jenkins/jobs/Run-FitNesse-tests/workspace/root
      logger: none
      authenticator: fitnesse.authentication.PromiscuousAuthenticator
      page factory: fitnesse.responders.PageFactory
      page theme: fitnesse_straight
      page version expiration set to 14 days.

      Connnecting to http://localhost:7100/TestSuite?suite&format=xml&includehtml
      Connected: 200/OK
      Force close of input stream.
      Xml results saved as UTF-8 to /var/lib/jenkins/jobs/Run-FitNesse-tests/workspace/fitnesse.xml
      Reading results as UTF-8 from /var/lib/jenkins/jobs/Run-FitNesse-tests/workspace/fitnesse.xml
      Parsing results...
      javax.xml.transform.TransformerException: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Verarbeitungsanweisungsziel, das "[xX][mM][lL]" entspricht, ist nicht zulässig.
      (Stacktrace removed)

      The content of the output fitnesse.xml indicates that no tests were executed:

      <?xml version="1.0"?>
      <testResults>
      <FitNesseVersion>v20130530</FitNesseVersion>
      <rootPath>TestSuite</rootPath>

      <finalCounts>
      <right>0</right>
      <wrong>0</wrong>
      <ignores>0</ignores>
      <exceptions>0</exceptions>
      </finalCounts>
      <totalRunTimeInMillis>0</totalRunTimeInMillis>

      </testResults>

      <?xml version="1.0"?>
      <testResults>
      <FitNesseVersion>v20130530</FitNesseVersion>
      <rootPath>TestSuite</rootPath>

      <finalCounts>
      <right>0</right>
      <wrong>0</wrong>
      <ignores>0</ignores>
      <exceptions>0</exceptions>
      </finalCounts>
      <totalRunTimeInMillis>0</totalRunTimeInMillis>

      </testResults>

      <?xml version="1.0"?>
      <testResults>
      <FitNesseVersion>v20130530</FitNesseVersion>
      <rootPath>TestSuite</rootPath>

      <finalCounts>
      <right>0</right>
      <wrong>0</wrong>
      <ignores>0</ignores>
      <exceptions>0</exceptions>
      </finalCounts>
      <totalRunTimeInMillis>1162</totalRunTimeInMillis>

      </testResults>

      (The repetition is as it appears in the file)

      When I use exactly the same command to start FitNesse as the jenkins user and access exactly the same URL to run the tests, they run correctly. Similarly, when I run FitNesse by hand and then start the job, the tests also run correctly. This problem only appears when the plugin runs the server itself.

      Attachments

        Activity

          hovinen Bradford Hovinen created issue -

          duplicate of JENKINS-20174

          antoine_aumjaud Antoine Aumjaud added a comment - duplicate of JENKINS-20174
          antoine_aumjaud Antoine Aumjaud made changes -
          Field Original Value New Value
          Resolution Duplicate [ 3 ]
          Status Open [ 1 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 158892 ] JNJira + In-Review [ 208101 ]

          People

            Unassigned Unassigned
            hovinen Bradford Hovinen
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: