Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25459

Authorization by "Github Commiter" strategy broken.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: github-oauth-plugin
    • Labels:
      None
    • Environment:
      github-oauth-plugin version 1.59
    • Similar Issues:

      Description

      Suddenly, when using the "Github Commiter" authorization strategy, we're getting an exception. From the log:

      WARNING: Caught exception evaluating: it.items in /. Reason: java.lang.reflect.InvocationTargetException
      ...
      Caused by: java.util.concurrent.ExecutionException: java.io.FileNotFoundException: https://api.github.com/repos/[redacted]/collaborators
      ...

      The API endpoint returns:

      {
      "message": "Not Found",
      "documentation_url": "https://developer.github.com/v3"
      }

        Attachments

          Issue Links

            Activity

            heiko Heiko Heijenga added a comment -

            Same problem here. Everyone in the 'Admin User Names' list can use Jenkins fine, anybody who's not receives exceptions all over the place.

            sag47 Sam Gleske added a comment -

            Since this issue is old I am closing it. Try using the latest release. If it is still an issue in the latest release then file a new issue and link back to this one.


              People

              Assignee:
              sag47 Sam Gleske
              Reporter:
              veshi adrian kalaveshi
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: