Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-261

Console raw text link should offer to show only tail

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Currently if you have a very large console output from a build, it will show two
      links: one to the HTML rendition, one to the text rendition. When trying to find
      the cause of failure for a build with a long log (mine are typically in the
      5-10Mb range), even clicking the raw text link freezes Firefox for a minute or
      so and renders the computer unusable. Would like a link to just see the tail of
      the log, similar to what is displayed in a build failure email, since most
      errors can be diagnosed just from the end of the log.

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Maybe what we need is for the GUI console page to do something really smart,
          like just showing the tail portion first then incrementally fetch the rest of
          the log backward till it hit the top?

          jglick Jesse Glick added a comment -

          No, I don't want it show the rest of the log at all unless explicitly requested;
          it will freeze the browser. Even if the tail shows up first, it will soon become
          impossible to scroll around just in the tail if megabytes more text are added at
          the top. In fact, the 100% CPU usage will likely make even the text currently on
          screen not display, in case you switch to a different desktop and back, because
          the browser will not get a repaint event. Open
          http://deadlock.nbextras.org/hudson/job/javadoc-nbms/292/console (when you have
          no unsaved data in your browser!) and see what I mean.

          Possible combined UI that would replace the current, somewhat clumsy, pair of
          "Console" and "[raw]" links:

          1. If the log is small, "Console" displays the regular live scrolling log, with
          a "Plain Text" link mainly for those who want to download it.

          2. If the log is big, "Console" displays just the tail of the log (in an HTML
          page without JavaScript), with both a "Full Text" link for the complete live
          scrolling log (if you have a very fast CPU and are feeling lucky), and a "Plain
          Text" link for the complete text for download.

          jglick Jesse Glick added a comment -

          Correcting subcomponent.

          mindless Alan Harder added a comment -

          started

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : mindless
          Path:
          trunk/hudson/main/core/src/main/resources/hudson/model/Run/console.jelly
          trunk/hudson/main/core/src/main/resources/hudson/model/Run/console.properties
          trunk/hudson/main/core/src/main/resources/hudson/model/Run/consoleFull.jelly
          trunk/hudson/main/core/src/main/resources/lib/hudson/progressiveText.jelly
          trunk/www/changelog.html
          http://fisheye4.cenqua.com/changelog/hudson/?cs=16119
          Log:
          [FIXED JENKINS-261] Only show last 150KB of console log by default in HTML view,
          with link to show entire log. Tail threshold of 150KB can be overridden with
          "hudson.consoleTailKB" java system property.

          jglick Jesse Glick added a comment -

          Cool, looking forward to trying it.


            People

            Assignee:
            mindless Alan Harder
            Reporter:
            jglick Jesse Glick
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: