Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26199

CpsScriptTest.evaluateShallBeCpsTransformed failures

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      After several rounds of trial-and-error with 'head', and tag 'workflow-1.1' I'm still not sure why tests fail. Currently I'm using Ubuntu 14.04 / JDK 1.8.0_25 (I had open-jdk7), and I've installed all the stuff that tests threw at me (e.g. mercurial). I assigned port 8081 to my local Jenkins test installation, and removed ~/.jenkins (which mvn hpi:run uses if it exists). Normally I use Eclipse following the Jenkins plugin development recommendations, but I also tried using Netbeans (8.02) (which brought even more problems).

      Right now I still need to remove most of the tests from
      cps/src/test/groovy/org/jenkinsci/plugins/workflow/cps/CpsScriptTest.groovy in order to get the workflow-plugin running.

      Possibly there are system dependencies that my workstation doesn't meet. I know that the Java platform is supposed to be OS independent, but obviously it's not that simple. It would be very helpful if there were a list of requirements for the build- and test environment (Linux, BSD, Mac, Windows, distribution, installed software ... ).

        Attachments

          Issue Links

            Activity

            tg9541 Thomas Goeppel created issue -
            jglick Jesse Glick made changes -
            Field Original Value New Value
            Issue Type Improvement [ 4 ] Task [ 3 ]
            Labels testing
            jglick Jesse Glick made changes -
            Assignee Jesse Glick [ jglick ] Kohsuke Kawaguchi [ kohsuke ]
            Summary Build system requirements not listed CpsScriptTest.evaluateShallBeCpsTransformed failures
            jglick Jesse Glick made changes -
            Link This issue depends on JENKINS-18578 [ JENKINS-18578 ]
            jglick Jesse Glick made changes -
            Assignee Kohsuke Kawaguchi [ kohsuke ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 160190 ] JNJira + In-Review [ 180286 ]
            abayer Andrew Bayer made changes -
            Component/s pipeline-general [ 21692 ]
            abayer Andrew Bayer made changes -
            Component/s workflow-plugin [ 18820 ]
            jglick Jesse Glick made changes -
            Resolution Cannot Reproduce [ 5 ]
            Status Open [ 1 ] Resolved [ 5 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              tg9541 Thomas Goeppel
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: