Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26398

Fix createSlave for RestartableJenkinsRule

    XMLWordPrintable

Details

    • 1746.v2b_3c5d1983b_e

    Description

      If you use JenkinsRule.createSlave (or createOnlineSlave) from a test based on RestartableJenkinsRule, it seems to work during the first session. But then the whole slave directory gets quietly deleted during the restart.

      Either this deletion should be suppressed, or there should be an alternate method to create a slave that actually survives the restart intact.

      See WorkflowTest.buildShellScriptAcrossRestart and BindingStepTest.cleanupAfterRestart.

      Attachments

        Issue Links

          Activity

            jglick Jesse Glick created issue -
            jglick Jesse Glick added a comment -

            The workaround is to add a DumbSlave manually.

            jglick Jesse Glick added a comment - The workaround is to add a DumbSlave manually.
            jglick Jesse Glick made changes -
            Field Original Value New Value
            Issue Type Improvement [ 4 ] Bug [ 1 ]

            Code changed in jenkins
            User: Jesse Glick
            Path:
            src/test/java/org/jenkinsci/plugins/credentialsbinding/impl/BindingStepTest.java
            http://jenkins-ci.org/commit/credentials-binding-plugin/615c102baa4942f96e1bef415b67d628329060ce
            Log:
            Found workaround for JENKINS-26398, which was the key to getting this test to pass.

            Compare: https://github.com/jenkinsci/credentials-binding-plugin/compare/4640f27f13e4...615c102baa49

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Jesse Glick Path: src/test/java/org/jenkinsci/plugins/credentialsbinding/impl/BindingStepTest.java http://jenkins-ci.org/commit/credentials-binding-plugin/615c102baa4942f96e1bef415b67d628329060ce Log: Found workaround for JENKINS-26398 , which was the key to getting this test to pass. Compare: https://github.com/jenkinsci/credentials-binding-plugin/compare/4640f27f13e4...615c102baa49

            Code changed in jenkins
            User: Jesse Glick
            Path:
            aggregator/src/test/java/org/jenkinsci/plugins/workflow/WorkflowTest.java
            http://jenkins-ci.org/commit/workflow-plugin/73d09e62b8b094f2865d1aab32044cf402965108
            Log:
            JENKINS-26398 Linking to a filed issue.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Jesse Glick Path: aggregator/src/test/java/org/jenkinsci/plugins/workflow/WorkflowTest.java http://jenkins-ci.org/commit/workflow-plugin/73d09e62b8b094f2865d1aab32044cf402965108 Log: JENKINS-26398 Linking to a filed issue.

            Code changed in jenkins
            User: Jesse Glick
            Path:
            aggregator/src/test/java/org/jenkinsci/plugins/workflow/WorkflowTest.java
            http://jenkins-ci.org/commit/workflow-plugin/dd5eaf7aa09cc509fb98f46816fad2b2b337b5ea
            Log:
            Merge pull request #34 from jenkinsci/JENKINS-26398-comment

            Linking to a filed issue

            Compare: https://github.com/jenkinsci/workflow-plugin/compare/375c1db37f91...dd5eaf7aa09c

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Jesse Glick Path: aggregator/src/test/java/org/jenkinsci/plugins/workflow/WorkflowTest.java http://jenkins-ci.org/commit/workflow-plugin/dd5eaf7aa09cc509fb98f46816fad2b2b337b5ea Log: Merge pull request #34 from jenkinsci/ JENKINS-26398 -comment Linking to a filed issue Compare: https://github.com/jenkinsci/workflow-plugin/compare/375c1db37f91...dd5eaf7aa09c
            jglick Jesse Glick made changes -
            Link This issue is related to JENKINS-25975 [ JENKINS-25975 ]
            jglick Jesse Glick added a comment -

            Could do that, but some of the tests also seem to require use of a JNLP slave, which is rather more complicated to model. Punting for the moment.

            jglick Jesse Glick added a comment - Could do that, but some of the tests also seem to require use of a JNLP slave, which is rather more complicated to model. Punting for the moment.

            Maybe split slave creation into KillableSlaveRule for example and bind it where required to JenkinsRule?

            integer Kanstantsin Shautsou added a comment - Maybe split slave creation into KillableSlaveRule for example and bind it where required to JenkinsRule?
            jglick Jesse Glick added a comment -

            I think would suffice to add methods to JenkinsRule.

            jglick Jesse Glick added a comment - I think would suffice to add methods to JenkinsRule .

            Code changed in jenkins
            User: Jesse Glick
            Path:
            aggregator/src/test/java/org/jenkinsci/plugins/workflow/WorkflowTest.java
            http://jenkins-ci.org/commit/workflow-cps-plugin/ec779e6d6937e5d7777e11a03d415f76a11bff74
            Log:
            JENKINS-26398 Linking to a filed issue.
            Originally-Committed-As: 73d09e62b8b094f2865d1aab32044cf402965108

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Jesse Glick Path: aggregator/src/test/java/org/jenkinsci/plugins/workflow/WorkflowTest.java http://jenkins-ci.org/commit/workflow-cps-plugin/ec779e6d6937e5d7777e11a03d415f76a11bff74 Log: JENKINS-26398 Linking to a filed issue. Originally-Committed-As: 73d09e62b8b094f2865d1aab32044cf402965108
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 160464 ] JNJira + In-Review [ 180362 ]
            abayer Andrew Bayer made changes -
            Labels testing workflow pipeline testing workflow
            abayer Andrew Bayer made changes -
            Labels pipeline testing workflow pipeline testing
            oleg_nenashev Oleg Nenashev made changes -
            Component/s jenkins-test-harness [ 21462 ]
            Component/s core [ 15593 ]
            jglick Jesse Glick added a comment -

            Need to recheck with JenkinsSessionRule.

            jglick Jesse Glick added a comment - Need to recheck with JenkinsSessionRule .
            jglick Jesse Glick added a comment -

            Still a problem with JenkinsSessionRule. The issue is that JenkinsSessionRule.tmp survives restarts but JenkinsRule.env.temporaryDirectoryAllocator as used by createTmpDir does not, and createSlave still uses createTmpDir. Options include

            • use some other agent root dir (e.g. inside $JENKINS_HOME)
            • use a TemporaryFolder scoped to JenkinsSessionRule
            • allow JenkinsRule.env to be overridden from JenkinsSessionRule
            jglick Jesse Glick added a comment - Still a problem with JenkinsSessionRule . The issue is that JenkinsSessionRule.tmp survives restarts but JenkinsRule.env.temporaryDirectoryAllocator as used by createTmpDir does not, and createSlave still uses createTmpDir . Options include use some other agent root dir (e.g. inside $JENKINS_HOME ) use a TemporaryFolder scoped to JenkinsSessionRule allow JenkinsRule.env to be overridden from JenkinsSessionRule
            jglick Jesse Glick made changes -
            Assignee Jesse Glick [ jglick ]
            jglick Jesse Glick made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            jglick Jesse Glick made changes -
            Remote Link This issue links to "jenkins-test-harness #428 (Web Link)" [ 27706 ]
            jglick Jesse Glick made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            jglick Jesse Glick made changes -
            Released As 1746.v2b_3c5d1983b_e
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Resolved [ 5 ]

            People

              jglick Jesse Glick
              jglick Jesse Glick
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: