Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26970

Jenkins website: Community ratings in changelog no longer working

    XMLWordPrintable

Details

    Description

      In the Jenkins website, go to the changelog page (or the LTS changelog), and click the "Community Ratings" link: It not longer works.

      With browser dev tools open, we can see that clicking the link generates two JS errors.

      I wasn't sure where to report this error, since it's an issue with the site rather than with Jenkins itself. I hope this is the right place.

      Attachments

        Activity

          danielbeck Daniel Beck added a comment -

          Sure, but wouldn't help anything as a PR has already been proposed to fix this at https://github.com/jenkins-infra/infra-rating/pull/4

          danielbeck Daniel Beck added a comment - Sure, but wouldn't help anything as a PR has already been proposed to fix this at https://github.com/jenkins-infra/infra-rating/pull/4
          mach David Mach added a comment -

          Mea culpa, may I create a new issue?

          mach David Mach added a comment - Mea culpa, may I create a new issue?
          danielbeck Daniel Beck added a comment -

          Also, completely different issue.

          danielbeck Daniel Beck added a comment - Also, completely different issue.
          danielbeck Daniel Beck added a comment -

          Don't reopen duplicates.

          danielbeck Daniel Beck added a comment - Don't reopen duplicates.
          mach David Mach added a comment -

          The problem is still here. When I click on link "Community ratings" on page "Changelog" (https://jenkins-ci.org/changelog), browser (Chrome, Firefox) show me just legend without ratings on every release. Internet Explorer redirect me to address https://jenkins-ci.org/.

          There is a hint in Firebug console: graphical assets are downloaded from unsecure address (without https) so browser ignore it. After click on link "Community ratings" browser throws into console this error:

          The page at 'https://jenkins-ci.org/changelog' was loaded over HTTPS, but ran insecure content from 'http://jenkins-ci.org/rate/result.php': this content should also be loaded over HTTPS.

          Hope this helps you!

          mach David Mach added a comment - The problem is still here. When I click on link "Community ratings" on page "Changelog" ( https://jenkins-ci.org/changelog ), browser (Chrome, Firefox) show me just legend without ratings on every release. Internet Explorer redirect me to address https://jenkins-ci.org/ . There is a hint in Firebug console: graphical assets are downloaded from unsecure address (without https) so browser ignore it. After click on link "Community ratings" browser throws into console this error: The page at 'https://jenkins-ci.org/changelog' was loaded over HTTPS, but ran insecure content from 'http://jenkins-ci.org/rate/result.php': this content should also be loaded over HTTPS. Hope this helps you!
          danielbeck Daniel Beck added a comment -

          I wasn't sure where to report this error, since it's an issue with the site rather than with Jenkins itself. I hope this is the right place.

          https://wiki.jenkins-ci.org/display/JENKINS/How+to+report+an+issue section "Creating the issue"

          danielbeck Daniel Beck added a comment - I wasn't sure where to report this error, since it's an issue with the site rather than with Jenkins itself. I hope this is the right place. https://wiki.jenkins-ci.org/display/JENKINS/How+to+report+an+issue section "Creating the issue"
          danielbeck Daniel Beck added a comment -

          Duplicates INFRA-234.

          danielbeck Daniel Beck added a comment - Duplicates INFRA-234.

          People

            Unassigned Unassigned
            simonc_sfw Simon C
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: