Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27251

windows slaves disconnect during build

    XMLWordPrintable

Details

    • Bug
    • Status: Reopened (View Workflow)
    • Critical
    • Resolution: Unresolved
    • remoting
    • None
    • Maser windows 2012R2 LTS version 1.580.1 windows slaves win7 , win81 win 2012 , win2012R2

    Description

      Matrix job execute MVN ( 3.0.5) step and the connection aborted
      08:20:57 FATAL: java.io.IOException: Connection aborted: org.jenkinsci.remoting.nio.NioChannelHub$MonoNioTransport@2760a63e[name=studio-7-1]
      08:20:57 hudson.remoting.RequestAbortedException: java.io.IOException: Connection aborted: org.jenkinsci.remoting.nio.NioChannelHub$MonoNioTransport@2760a63e[name=studio-

      I tried switch the MVN step with an ANT , it reduced dramatically the problem , but the problem still exist.

      attached a zip file contains 2 file the master log and the slave log - the problem happened at Mar 05, 2015 11:09:46

      Attachments

        1. jenkins.4.err.log
          763 kB
        2. jenkins-logs.zip
          742 kB
        3. jenkins-slave.5.err.log
          4.85 MB

        Activity

          oleg_nenashev Oleg Nenashev added a comment -

          Unfortunately I have no capacity to work on Remoting in medium term, so I will unassign it and let others to take it. If somebody is interested to submit a pull request, I will be happy to help to get it reviewed and released.

          oleg_nenashev Oleg Nenashev added a comment - Unfortunately I have no capacity to work on Remoting in medium term, so I will unassign it and let others to take it. If somebody is interested to submit a pull request, I will be happy to help to get it reviewed and released.

          Hi
          jenkins.4.err.log jenkins-slave.5.err.log
          It was on the 30.Nov 10:30pm. A little bit more to the setup. I have a master in the cloud and 3 slaves behind NATs.
          I never changed a default configuration of the slave or the master about how the connection should be established. Whats the best configuration for my scenario anyway?
          Thanks

          nerumo Marco Bachmann added a comment - Hi jenkins.4.err.log jenkins-slave.5.err.log It was on the 30.Nov 10:30pm. A little bit more to the setup. I have a master in the cloud and 3 slaves behind NATs. I never changed a default configuration of the slave or the master about how the connection should be established. Whats the best configuration for my scenario anyway? Thanks
          oleg_nenashev Oleg Nenashev added a comment -

          nerumo Could you please provide logs from both master and agent sides?

          oleg_nenashev Oleg Nenashev added a comment - nerumo Could you please provide logs from both master and agent sides?

          TL;DR I'm having this issue on windows with slave 2.62.2 and server 2.34. Right now it's with every build

          nerumo Marco Bachmann added a comment - TL;DR I'm having this issue on windows with slave 2.62.2 and server 2.34. Right now it's with every build
          oleg_nenashev Oleg Nenashev added a comment -

          It was likely SocketTimeoutException on the slave side in this case (fixed in 2.60 & released in 2.9).
          In order to confirm it, it would be useful to have a log from the slave side.

          oleg_nenashev Oleg Nenashev added a comment - It was likely SocketTimeoutException on the slave side in this case (fixed in 2.60 & released in 2.9). In order to confirm it, it would be useful to have a log from the slave side.

          People

            Unassigned Unassigned
            morlajb morlajb
            Votes:
            25 Vote for this issue
            Watchers:
            28 Start watching this issue

            Dates

              Created:
              Updated: