Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27989

Creating SSH Remote Host with "Pty" checked deletes all other existing SSH Remote Host entries

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: ssh-plugin
    • Labels:
      None
    • Environment:
      Jenkins v1.609
      Jenkins server: FC10
      SSH plugin v2.4
      brower=Chrome Version 42.0.2311.90 m; running on Windows XP
    • Similar Issues:

      Description

      Recipe:

      • create one or more SSH Remote Hosts via Manage Jenkins > Configure System
      • save config
      • verify that you can use these SSH hosts in your Projects
      • create a new SSH Remote Host and select the "Pty" button
      • save config
      • notice that all your previously created SSH Remote Hosts are gone.

        Attachments

          Activity

          randymarlow Randy Marlow created issue -
          johnnybgoode John Tatum added a comment -

          I was able to duplicate this issue, but in my case the result was that the new site was not saved. Instead, Pty was checked on the existing site and the new site was not saved.

          johnnybgoode John Tatum made changes -
          Field Original Value New Value
          URL https://issues.jenkins-ci.org/browse/JENKINS-22336
          Labels Duplicate
          johnnybgoode John Tatum made changes -
          Labels Duplicate
          johnnybgoode John Tatum added a comment -

          This issue appears to be a duplicate of https://issues.jenkins-ci.org/browse/JENKINS-22336.

          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 162589 ] JNJira + In-Review [ 180983 ]
          ljader Łukasz Jąder added a comment -

          Closing - this should be fixed and working in recently released SSH 2.5.

          ljader Łukasz Jąder made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Closed [ 6 ]
          cs_everhart Scott Everhart added a comment -

          Was this really fixed?  I didn't see anything about this issue in the v2.5 release notes.

          ljader Łukasz Jąder added a comment -

          Scott Everhart sorry for not updating the v2.5 release notes - I will do this hopefully this week.

          I ran few tests on adding and deleting the sites and it behaved as expected, so I marked this as fixed.

          cs_everhart Scott Everhart added a comment -

          Thanks for your quick reply.  I was having the same issue where it was marking the pty checkbox on the first site in the list and deleting all the rest of the ssh sites that had been set up.  So if that is fixed, it would be a big help for my team.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            randymarlow Randy Marlow
            Votes:
            3 Vote for this issue
            Watchers:
            7 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: