Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29352

SVN Polling does not accept system variable in repo URL

    XMLWordPrintable

Details

    Description

      After upgrading from a fairly old 1.5something to 1.619, polling jobs that have a system variable fail to poll and disable themselves, while emitting this message in the polling log:

      Location 'https://hostname.associatesys.local/svn/repos/reponame/common/branches/dev_OMCommon${BRANCH_SUFFIX_GREEN_LANTERN}' does not exist
      One or more repository locations do not exist anymore for hudson.maven.MavenModuleSet@68d6d18d[Green_Lantern_Commit], project will be disabled.
      Done. Took 83 ms
      No changes
      

      Attachments

        Issue Links

          Activity

            ryanhos, I sent a PR to resolve this.

            recena Manuel Recena Soto added a comment - ryanhos , I sent a PR to resolve this.

            ryanhos, Nice! I'll waiting for your feedback.

            recena Manuel Recena Soto added a comment - ryanhos , Nice! I'll waiting for your feedback.

            Subversion plugin version: 2.4.4.

            My installation was indicating I was only one build behind (2.4.5), but I updated and see 2.5.1 is now available.

            I can try the workspace wipe operation this afternoon after upgrading the plugin.

            ryanhos Ryan Hochstetler added a comment - Subversion plugin version: 2.4.4. My installation was indicating I was only one build behind (2.4.5), but I updated and see 2.5.1 is now available. I can try the workspace wipe operation this afternoon after upgrading the plugin.

            ryanhos It seems this bug is related to this one https://issues.jenkins-ci.org/browse/JENKINS-29340 You can find a very detailed description of the bug (a step by step process to reproduce it, screencasts, etc).

            recena Manuel Recena Soto added a comment - ryanhos It seems this bug is related to this one https://issues.jenkins-ci.org/browse/JENKINS-29340 You can find a very detailed description of the bug (a step by step process to reproduce it, screencasts, etc).
            recena Manuel Recena Soto added a comment - - edited

            ryanhos, Could you try "Wipe Out Current Workspace" and build again?

            1. Access to Jenkins
            2. Select your job
            3. Press on Workspace (left menu)
            4. Press on Wipe Out Current Workspace
            5. Press on Build Now

            What version of Subversion Plugin are you using? 2.5 or 2.5.1?

            recena Manuel Recena Soto added a comment - - edited ryanhos , Could you try " Wipe Out Current Workspace " and build again? Access to Jenkins Select your job Press on Workspace (left menu) Press on Wipe Out Current Workspace Press on Build Now What version of Subversion Plugin are you using? 2.5 or 2.5.1?

            People

              recena Manuel Recena Soto
              ryanhos Ryan Hochstetler
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: