Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29522

Rename master/slave to manager/worker

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      All
    • Similar Issues:

      Description

      How receptive would the jenkins community be to replacing the master/slave terminology? Django and drupal have already made such a switch – https://github.com/django/django/pull/2692, https://www.drupal.org/node/2275877 – and I think their reasoning applies to Jenkins as well.

      (One could bikeshed indefinitely on replacement terms, and I'm not wedded to manager/worker in any way.)

      Changing the code is probably the easier part (though not trivial); there's also lots of documentation that would need to change, not all of it written/maintained by the jenkins project. I think the proejct is worth it even if there is a long tail of references to master/slave references that stick around in docs.

        Attachments

          Issue Links

            Activity

            csilvers Craig Silverstein added a comment -

            Seems like it's been resolved!

            u6073771 Yashaswini TR added a comment -

            Hi Team,

            I need a help I need to change a Jnlp file of a slave. I mean in a slave jnlp file consists a master server name instead of that i need to add a master dns name and launch that slave agent.

            Im not able to do that, Can anyone please do help with that

            topher Topher Perusse added a comment -

            I would argue that this is not a duplicate of JENKINS-27268 - the term "master" really should be removed and I don't see any other stories reflecting this work. Can someone point to the story for that? Or re-open this for that work?

            markewaite Mark Waite added a comment - - edited

            Topher Perusse thanks for your interest. You're welcome to reopen this issue for that work or not.

            Reopening a ticket is much less likely to make progress on the work than opening a pull request to help with the issue. Some examples of pull requests that have moved the terminology work forward include:

            • Security advisories updated - PR-3632
            • Blog posts updated - PR-3678
            • Japanese references to slave replaced with agent - PR-4863
            • French references to slave replaced with agent - PR-4801
            • Replace some English references to slave with agent - PR-4777

            More details on the terminology changes are available from Alex Earl's Continuous Delivery Foundation blog post.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              csilvers Craig Silverstein
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: