Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29932

Docker build publish plugin throws error "Please login prior to push" after build the image

    XMLWordPrintable

Details

    Description

      [service] $ docker push registry/dev/service
      The push refers to a repository [registry/dev/service] (len: 1)
      Sending image list
      
      Please login prior to push:
      Username: EOF
      Build step 'Docker Build and Publish' marked build as failure
      

      Currently installed 'CloudBees Docker Build and Publish plugin' with version 1.0

      Attachments

        Activity

          dslupytskyi Dmytro Slupytskyi created issue -
          dslupytskyi Dmytro Slupytskyi made changes -
          Field Original Value New Value
          Attachment Screen Shot 2015-08-13 at 1.22.39 PM.png [ 30480 ]

          that means your credentials are incorrect

          csanchez Carlos Sanchez added a comment - that means your credentials are incorrect

          this is odd, because i use this credentials more than week or may be two. and no updates with jenkins or plugins recently was done

          created additional jenkins credentials for registry and it works (old jenkins credentials have incorrect password)

          thank you for help

          dslupytskyi Dmytro Slupytskyi added a comment - this is odd, because i use this credentials more than week or may be two. and no updates with jenkins or plugins recently was done created additional jenkins credentials for registry and it works (old jenkins credentials have incorrect password) thank you for help
          dslupytskyi Dmytro Slupytskyi made changes -
          Resolution Not A Defect [ 7 ]
          Status Open [ 1 ] Closed [ 6 ]
          mihirvora Mihir Vora added a comment -

          Sorry if i shouldn't open this issue again but i am running into the exact same issue,

          I have confirmed that the user id and password work fine by manually pushing the image from the remote slave, the issue is when i try to push the same using the plugin it breaks.

          Additionally if I try to

          docker login -u abcdef -p ******* -e abcdef@abc.com docker-registry.com

          <Plugin Step>

          docker logout docker-registry.com

          This setup works fine, seems to me like something is not getting passed (especially the credentials)

          Below are the details of the plugins installed
          CloudBees Docker Build and Publish plugin - 1.0
          Docker Commons Plugin - 1.2
          Credentials Plugin - 1.23

          Can you please help..!

          Thanks,
          Mihir

          mihirvora Mihir Vora added a comment - Sorry if i shouldn't open this issue again but i am running into the exact same issue, I have confirmed that the user id and password work fine by manually pushing the image from the remote slave, the issue is when i try to push the same using the plugin it breaks. Additionally if I try to docker login -u abcdef -p ******* -e abcdef@abc.com docker-registry.com <Plugin Step> docker logout docker-registry.com This setup works fine, seems to me like something is not getting passed (especially the credentials) Below are the details of the plugins installed CloudBees Docker Build and Publish plugin - 1.0 Docker Commons Plugin - 1.2 Credentials Plugin - 1.23 Can you please help..! Thanks, Mihir
          mihirvora Mihir Vora made changes -
          Resolution Not A Defect [ 7 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          kopax D KA added a comment -

          I have the same issue, I can't push the layer, it keep retrying.

          kopax D KA added a comment - I have the same issue, I can't push the layer, it keep retrying.
          mrichar2 Mark R added a comment - - edited

          I am having the same issue. I have the latest version of the plugin.

          mrichar2 Mark R added a comment - - edited I am having the same issue. I have the latest version of the plugin.
          mrichar2 Mark R added a comment -

          I attached a debugger and managed to figure out my issue. My /home/jenkins/.dockercfg file had both a http and https url endpoint for my registry. The https endpoint had the correct password set. The http one did not. This may have something to do with me recently changing my password. To correct it I removed the stale http entry.

          mrichar2 Mark R added a comment - I attached a debugger and managed to figure out my issue. My /home/jenkins/.dockercfg file had both a http and https url endpoint for my registry. The https endpoint had the correct password set. The http one did not. This may have something to do with me recently changing my password. To correct it I removed the stale http entry.
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 165010 ] JNJira + In-Review [ 186307 ]

          People

            csanchez Carlos Sanchez
            dslupytskyi Dmytro Slupytskyi
            Votes:
            3 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated: