Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30144

thinBackup does not backup Slave settings

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • thinbackup-plugin
    • None
    • Jenkins 1.609.1
      thinBackup 1.7.4

    Description

      Since jenkins v1.607,
      a slave definition is saved on "nodes/(slave name)/config.xml".

      https://jenkins-ci.org/changelog#v1.607

      What's new in 1.607 (2015/03/30)
      ...
      Refactor the Queue and Nodes to use a consistent locking strategy (issue 27565) Note that this change involved moving slave definitions outside the main config.xml file. If you downgrade after this, your slave settings will be lost.

      But, thinBackup does not backup nodes directory.

      Attachments

        Issue Links

          Activity

            tofuatjava Thomas Fürer added a comment -

            a solution to back up additional files should be part of 1.8.0. please upgrade and try again, but do not hesidate if it do not work as expected

            tofuatjava Thomas Fürer added a comment - a solution to back up additional files should be part of 1.8.0. please upgrade and try again, but do not hesidate if it do not work as expected

            Thank you.
            I tried it with following settings:

            • (.*\.xml)
            • nodes.*

            But it did not backup "nodes" directory..
            Something must be wrong with my settings..

            "nodes" directory is created by Jenkins normally.
            It seems to be better to backup this directory without any settings.

            ref. JENKINS-30423
            > Thinbackup should be updated to back-up "nodes/*/config.xml" files just like it does "jobs/*/config.xml" files.

            I'll try to implement it.

            kamuin Naoki Kawamukai added a comment - Thank you. I tried it with following settings: (.*\.xml) nodes.* But it did not backup "nodes" directory.. Something must be wrong with my settings.. "nodes" directory is created by Jenkins normally. It seems to be better to backup this directory without any settings. ref. JENKINS-30423 > Thinbackup should be updated to back-up "nodes/*/config.xml" files just like it does "jobs/*/config.xml" files. I'll try to implement it.

            > I'll try to implement it.
            Done. -> https://github.com/jenkinsci/thin-backup-plugin/pull/8
            Please check it.

            kamuin Naoki Kawamukai added a comment - > I'll try to implement it. Done. -> https://github.com/jenkinsci/thin-backup-plugin/pull/8 Please check it.

            Code changed in jenkins
            User: Naoki Kawamukai
            Path:
            src/main/java/org/jvnet/hudson/plugins/thinbackup/backup/HudsonBackup.java
            src/test/java/org/jvnet/hudson/plugins/thinbackup/TestHelper.java
            src/test/java/org/jvnet/hudson/plugins/thinbackup/backup/TestHudsonBackup.java
            http://jenkins-ci.org/commit/thin-backup-plugin/7ba83aac15b1a332951f49faea4a32b5ae872f4f
            Log:
            [FIX JENKINS-30144] backup nodes directory

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Naoki Kawamukai Path: src/main/java/org/jvnet/hudson/plugins/thinbackup/backup/HudsonBackup.java src/test/java/org/jvnet/hudson/plugins/thinbackup/TestHelper.java src/test/java/org/jvnet/hudson/plugins/thinbackup/backup/TestHudsonBackup.java http://jenkins-ci.org/commit/thin-backup-plugin/7ba83aac15b1a332951f49faea4a32b5ae872f4f Log: [FIX JENKINS-30144] backup nodes directory

            Thank you.
            I confirmed that this issue was fixed with thinBackup 1.9.0.

            kamuin Naoki Kawamukai added a comment - Thank you. I confirmed that this issue was fixed with thinBackup 1.9.0.

            People

              tofuatjava Thomas Fürer
              kamuin Naoki Kawamukai
              Votes:
              5 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: