Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30377

Schedule Build icon does not work on Jobs Grid view

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Schedule Build icon does not work on Jobs Grid view. Similar issue to https://issues.jenkins-ci.org/browse/JENKINS-28860 which was recently fixed.

        Attachments

          Issue Links

            Activity

            joshshinn Joshua Shinn created issue -
            Hide
            danielbeck Daniel Beck added a comment -

            Only when folders are involved?

            Show
            danielbeck Daniel Beck added a comment - Only when folders are involved?
            Hide
            joshshinn Joshua Shinn added a comment -

            Daniel Beck With or without folders

            Show
            joshshinn Joshua Shinn added a comment - Daniel Beck With or without folders
            Hide
            sergio19 sergio costa added a comment - - edited

            My Build icon in Jobs Grid View its not working also.
            Before I update the dashboard plugin to the latest one, it give-me an error, something like "cannot acess element: "url/view/viewName/view/viewName/job/jobName/build" (notice the duplicated view name in URL). This happens if in the grid there is a job from the view itself, if I include a job from another view it works.
            Today I updated dashboard plugin and occurs an error: Problem accessing /view/viewName/job/jobName/build. Reason:
            <pre> Nothing is submitted ..."
            This only happens with parameterized builds. Normal builds works nice.
            Jenkins v 1.606

            Show
            sergio19 sergio costa added a comment - - edited My Build icon in Jobs Grid View its not working also. Before I update the dashboard plugin to the latest one, it give-me an error, something like "cannot acess element: "url/view/viewName/view/viewName/job/jobName/build" (notice the duplicated view name in URL). This happens if in the grid there is a job from the view itself, if I include a job from another view it works. Today I updated dashboard plugin and occurs an error: Problem accessing /view/viewName/job/jobName/build. Reason: <pre> Nothing is submitted ..." This only happens with parameterized builds. Normal builds works nice. Jenkins v 1.606
            rtyler R. Tyler Croy made changes -
            Field Original Value New Value
            Workflow JNJira [ 165481 ] JNJira + In-Review [ 181991 ]
            Hide
            sag47 Sam Gleske added a comment - - edited

            The root cause of this issue for me is enabling CSRF support in Global Security config. From my Jenkins log.

            Sep 12, 2016 12:34:05 AM hudson.security.csrf.CrumbFilter doFilter
            WARNING: No valid crumb was included in request for /job/gimp-master/build. Returning 403.
            Sep 12, 2016 12:34:50 AM hudson.security.csrf.CrumbFilter doFilter
            WARNING: No valid crumb was included in request for /job/gimp-master/build. Returning 403.
            Sep 12, 2016 12:34:55 AM hudson.security.csrf.CrumbFilter doFilter
            

            I get the 403 when I click the "build job" icon in the Jobs Grid view. I have it configured in the All view. You may see my Jenkins at https://build.gimp.org/

            Environment:
            Debian Sid using Jenkins from http://pkg.jenkins-ci.org/debian-stable/
            Jenkins 2.7.4
            dashboard-view 2.9.10

            Show
            sag47 Sam Gleske added a comment - - edited The root cause of this issue for me is enabling CSRF support in Global Security config. From my Jenkins log. Sep 12, 2016 12:34:05 AM hudson.security.csrf.CrumbFilter doFilter WARNING: No valid crumb was included in request for /job/gimp-master/build. Returning 403. Sep 12, 2016 12:34:50 AM hudson.security.csrf.CrumbFilter doFilter WARNING: No valid crumb was included in request for /job/gimp-master/build. Returning 403. Sep 12, 2016 12:34:55 AM hudson.security.csrf.CrumbFilter doFilter I get the 403 when I click the "build job" icon in the Jobs Grid view. I have it configured in the All view. You may see my Jenkins at https://build.gimp.org/ Environment: Debian Sid using Jenkins from http://pkg.jenkins-ci.org/debian-stable/ Jenkins 2.7.4 dashboard-view 2.9.10
            cloudbees CloudBees Inc. made changes -
            Remote Link This issue links to "CloudBees Internal OSS-424 (Web Link)" [ 18892 ]
            tgr Tobias Gruetzmacher made changes -
            Assignee Peter Hayes [ petehayes ] Tobias Gruetzmacher [ tgr ]
            Hide
            tgr Tobias Gruetzmacher added a comment -
            Show
            tgr Tobias Gruetzmacher added a comment - Should be fixed with https://github.com/jenkinsci/dashboard-view-plugin/commit/a2e527408eeaed855ec45f8060078e522e93bd4b - will be part of the next release
            tgr Tobias Gruetzmacher made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Fixed but Unreleased [ 10203 ]
            tgr Tobias Gruetzmacher made changes -
            Released As https://github.com/jenkinsci/dashboard-view-plugin/releases/tag/dashboard-view-2.11
            Status Fixed but Unreleased [ 10203 ] Resolved [ 5 ]

              People

              Assignee:
              tgr Tobias Gruetzmacher
              Reporter:
              joshshinn Joshua Shinn
              Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: