Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-306

SVN Update change log is throwing NullPointerException, breaking build

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      When I run a build after an SVN update, I'm getting a NullPointerException.
      Again, this is Tomcat 5.5 under JRE 1.4.2_10, with a SVN 1.4:
      (from the console out page)
      started
      Updating file:///c:/svnrepo/simpletest
      U src/runtime/com/hewitt/twgi/ci/simpletest/SimpleFrame.java
      src/runtime/com/hewitt/twgi/ci/simpletest
      src/runtime/com/hewitt/twgi/ci
      src/runtime/com/hewitt/twgi
      src/runtime/com/hewitt
      src/runtime/com
      src/runtime
      src
      At revision 5
      FATAL: null
      java.lang.NullPointerException
      at
      org.apache.xalan.transformer.TransformerIdentityImpl.flushStartDoc(TransformerIdentityImpl.java:888)
      at
      org.apache.xalan.transformer.TransformerIdentityImpl.startElement(TransformerIdentityImpl.java:1019)
      at
      org.tmatesoft.svn.core.wc.xml.AbstractXMLHandler.openTag(AbstractXMLHandler.java:79)
      at
      org.tmatesoft.svn.core.wc.xml.SVNXMLLogHandler.sendToHandler(SVNXMLLogHandler.java:94)
      at
      org.tmatesoft.svn.core.wc.xml.SVNXMLLogHandler.handleLogEntry(SVNXMLLogHandler.java:82)
      at org.tmatesoft.svn.core.wc.SVNLogClient$2.handleLogEntry(SVNLogClient.java:552)
      at
      org.tmatesoft.svn.core.internal.io.fs.FSRepository.sendChanges(FSRepository.java:1065)
      at org.tmatesoft.svn.core.internal.io.fs.FSRepository.log(FSRepository.java:617)
      at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:568)
      at hudson.scm.SubversionSCM.calcChangeLog(SubversionSCM.java:164)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:236)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:267)
      at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:141)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:107)
      at hudson.model.Run.run(Run.java:533)
      at hudson.model.Build.run(Build.java:99)
      at hudson.model.Executor.run(Executor.java:61)

        Attachments

          Activity

          dtertman dtertman added a comment -

          Rockin'. Thanks!

          kohsuke Kohsuke Kawaguchi added a comment -

          I put a work around in Hudson for this. Fixed in 1.84.

          kohsuke Kohsuke Kawaguchi added a comment -

          I spent too much time trying to find xalan.jar, and it turns out it was coming
          from JDK 1.4!

          I have to find 1.4.2_10...

          dtertman dtertman added a comment -

          Whoops - looks like my first comment got lost with the attachment upload. I can
          reproduce the issue in Tomcat 5.5.20 under JRE 1.4.2_10 with the matching Tomcat
          compatibility pack.

          dtertman dtertman added a comment -

          Also - in the Hudson job descriptor, I am checking the "use update" SVN box.
          Haven't tried it unchecked.

          dtertman dtertman added a comment -

          Created an attachment (id=39)
          svn repository - unzip to c:

          kohsuke Kohsuke Kawaguchi added a comment -

          Can you tell me the exact version of Tomcat that you are using? I'd like to find
          out what's in
          org.apache.xalan.transformer.TransformerIdentityImpl.flushStartDoc(TransformerIdentityImpl.java:888)
          but I can't match it up with what Hudson bundles in itself.

          Also, would it be possible for you to try a different repositories and see if
          you get the same problem? Otherwise, I saw that you have a test repository in
          your log — is it possible for you to send that repository data to me?

          I'm basically trying to get the problem reproduced.

          Finally, what would you say if I ask you to build Hudson and run it under the
          debugger, and see what's going on that line? The instruction to build and run
          Hudson can be found at https://hudson.dev.java.net/workspace.html


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            dtertman dtertman
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: