Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30745

First poll does not run on copied jobs which aren't yet saved or applied

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      When i creat a new job by copying another job, the first poll does not run.
      Even when i click "poll now" the poll does not seem to run.
      If i open the configuration of the new job and save, the polling starts to work.

      Any ideas what the problem is? I am happy to provide logs but i am unsure which loggers to use?

      This is causing major problems for us because we have automated job creation to copy a template job. At the moment all these jobs need to be manually re-saved in order to run which is causing much delay.

        Attachments

          Issue Links

            Activity

            integer Kanstantsin Shautsou added a comment - - edited

            Guys, that's all dirty hack and pure jenkins API/code place. Solution should be provided/resolved through JENKINS-30802

            yakobe jake bishop added a comment -

            Kanstantsin Shautsou I'm a bit confused again by what you mean. Are you saying that copying a job with the API is a hack? Or are you saying that JENKINS-30802 will provide a solution to allow jobs to be copied over the API? From my view it should be possible to copy jobs using the API...

            yakobe jake bishop added a comment -

            Kanstantsin Shautsou I see you updated your message but it is still not clear what you mean. Even if i use the standard rest API (not the scripts from entagen) i am not able to copy a job and get it to a state where polling works (due to the changes with this activation stuff). It really feals like a bug

            danielbeck Daniel Beck added a comment -

            jake bishop IIRC newly copied jobs should have no "Build Now" link in the sidepanel until you save the config form. Are you saying that's not the case?

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            changelog.html
            http://jenkins-ci.org/commit/jenkins/f53b529fa0f7abb3e936b3c19214ee20116b811c
            Log:
            Noting the revert of https://github.com/jenkinsci/jenkins/pull/1617 in #1870 (JENKINS-30745)


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              yakobe jake bishop
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: