Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32039

"screen" default does not work

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed (View Workflow)
    • Trivial
    • Resolution: Fixed
    • xvfb-plugin
    • None

    Description

      The documentation says:
      Xvfb screen changes the screen resolution and pixel depth, it needs to be in WxHxD format (i.e. 1600x1200x24). The default is 1024x768x24.

      I just installed the xvfb-plugin, and took all the defaults, leaving the "screen" value blank. When running my Jenkins job, the first time, in the log I could see:

      Xvfb starting$ Xvfb :1 -screen 0  -fbdir /var/lib/jenkins/xvfb-99-1021388786522495009.fbdir
      

      and at the end of the job:

      Xvfb stopping
      Finished: SUCCESS 
      

      Running the exact same job every subsequent time, the log say:

      Xvfb starting$ Xvfb :1 -screen 0  -fbdir /var/lib/jenkins/xvfb-100-2665068639033469958.fbdir
      
      ERROR: Xvfb failed to start, consult the lines above for errors
      

      Looking at running jobs (using `ps -ef | grep -i xvfb`), I got nothing.

      Trying this same command from the command line interface, I get:

      $ Xvfb :1 -screen 0  -fbdir /var/lib/jenkins/xvfb-106-4356636144193454909.fbdir
      
      Invalid screen configuration -fbdir for -screen 0
      

      Finally I decided to specify something for the "screen" parameter - I used the supposed default: "1024x768x24" - and everything worked fine.

      Attachments

        Activity

          siking Mark Lehky created issue -
          siking Mark Lehky made changes -
          Field Original Value New Value
          Description The [documentation|https://wiki.jenkins-ci.org/display/JENKINS/Xvfb+Plugin#XvfbPlugin-ProjectConfiguration] says:
          ??*Xvfb screen* changes the screen resolution and pixel depth, it needs to be in WxHxD format (i.e. 1600x1200x24). The default is 1024x768x24.??

          I just installed the xvfb-plugin, and took all the defaults, leaving the "screen" value blank. When running my Jenkins job, the *first time*, in the log I could see:

          {noformat}
          Xvfb starting$ Xvfb :1 -screen 0 -fbdir /var/lib/jenkins/xvfb-99-1021388786522495009.fbdir
          {noformat}

          and at the end of the job:

          {noformat}
          Xvfb stopping
          Finished: SUCCESS
          {noformat}

          Running the exact same job *every subsequent time*, the log say:

          {noformat}
          Xvfb starting$ Xvfb :1 -screen 0 -fbdir /var/lib/jenkins/xvfb-100-2665068639033469958.fbdir

          ERROR: Xvfb failed to start, consult the lines above for errors
          {noformat}

          Looking at running jobs (using `ps -ef | grep -i xvfb`), I got nothing.

          Trying this same command from the command line interface, I get:

          {noformat}
          $ Xvfb :1 -screen 0 -fbdir /var/lib/jenkins/xvfb-106-4356636144193454909.fbdir

          Invalid screen configuration -fbdir for -screen 0
          {noformat}

          Finally I decided to specify something for the "screen" parameter - I used the _supposed_ default: "1024x768x24" and everything worked fine.
          The [documentation|https://wiki.jenkins-ci.org/display/JENKINS/Xvfb+Plugin#XvfbPlugin-ProjectConfiguration] says:
          ??*Xvfb screen* changes the screen resolution and pixel depth, it needs to be in WxHxD format (i.e. 1600x1200x24). The default is 1024x768x24.??

          I just installed the xvfb-plugin, and took all the defaults, leaving the "screen" value blank. When running my Jenkins job, the *first time*, in the log I could see:

          {noformat}
          Xvfb starting$ Xvfb :1 -screen 0 -fbdir /var/lib/jenkins/xvfb-99-1021388786522495009.fbdir
          {noformat}

          and at the end of the job:

          {noformat}
          Xvfb stopping
          Finished: SUCCESS
          {noformat}

          Running the exact same job *every subsequent time*, the log say:

          {noformat}
          Xvfb starting$ Xvfb :1 -screen 0 -fbdir /var/lib/jenkins/xvfb-100-2665068639033469958.fbdir

          ERROR: Xvfb failed to start, consult the lines above for errors
          {noformat}

          Looking at running jobs (using `ps -ef | grep -i xvfb`), I got nothing.

          Trying this same command from the command line interface, I get:

          {noformat}
          $ Xvfb :1 -screen 0 -fbdir /var/lib/jenkins/xvfb-106-4356636144193454909.fbdir

          Invalid screen configuration -fbdir for -screen 0
          {noformat}

          Finally I decided to specify something for the "screen" parameter - I used the _supposed_ default: "1024x768x24" - and everything worked fine.
          zregvart zregvart made changes -
          Priority Major [ 3 ] Trivial [ 5 ]
          zregvart zregvart made changes -
          Issue Type Bug [ 1 ] Improvement [ 4 ]
          zregvart zregvart made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          zregvart zregvart made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 167514 ] JNJira + In-Review [ 209537 ]

          People

            zregvart zregvart
            siking Mark Lehky
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: