Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3218

Hudson LDAP authentification is Case Sensitive

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Fixed
    • ldap-plugin
    • None
    • Platform: PC, OS: Windows 2000

    Description

      Hudson HudsoLDAP authentification is case sensitive. LDAP doesn't do case
      comparaison during login verification on LDAP side. But Hudson does. I enter
      following user in my project matrix table:

      "Arnold Pipo" (with all access: Administrator)

      When I try to connect with following id: "arnold pipo", I can connect but with
      only anonymous rights. If I cannot with "Arnold Pipo", I have the correct rights
      that I defined in my matrix. It seems that authentification is ok on LDAP side,
      but Hudson seems to compare "Arnold Pipo" and "arnold pipo" but it doesn't match
      (Case problem). So it considers him as anonymous user.

      Attachments

        Issue Links

          Activity

            taillant taillant created issue -
            tacianotres Taciano Tres added a comment -

            This issue is someway related to JENKINS-4354?

            tacianotres Taciano Tres added a comment - This issue is someway related to JENKINS-4354 ?
            williamleara williamleara added a comment -

            Similar to:
            http://issues.jenkins-ci.org/browse/JENKINS-6377

            ...which is written up vs. Active Directory.

            williamleara williamleara added a comment - Similar to: http://issues.jenkins-ci.org/browse/JENKINS-6377 ...which is written up vs. Active Directory.
            jglick Jesse Glick made changes -
            Field Original Value New Value
            Component/s ldap [ 17122 ]
            Component/s security [ 15508 ]
            jglick Jesse Glick made changes -
            Link This issue is duplicated by JENKINS-9771 [ JENKINS-9771 ]
            cforce cforce added a comment - Please fix, there so many different requests! Related/Dupe to https://issues.jenkins-ci.org/browse/JENKINS-3218 https://issues.jenkins-ci.org/browse/JENKINS-6377 https://issues.jenkins-ci.org/browse/JENKINS-4354 https://issues.jenkins-ci.org/browse/JENKINS-4354 https://issues.jenkins-ci.org/browse/JENKINS-4550 https://issues.jenkins-ci.org/browse/JENKINS-5436
            mdkf Michael Fowler made changes -
            Link This issue is related to JENKINS-17674 [ JENKINS-17674 ]

            I just had a problem with the same root cause: Jenkins didn't find my groups because I accidentally had one uppercase letter in my username during login.
            I think the login should either fail with wrong casing or Jenkins should just update the username from LDAP, so it continues with the correct username instead of the one with bad casing form the login.

            quick_wango Phillip Schichtel added a comment - I just had a problem with the same root cause: Jenkins didn't find my groups because I accidentally had one uppercase letter in my username during login. I think the login should either fail with wrong casing or Jenkins should just update the username from LDAP, so it continues with the correct username instead of the one with bad casing form the login.
            jglick Jesse Glick made changes -
            Link This issue is related to JENKINS-22247 [ JENKINS-22247 ]
            oleg_nenashev Oleg Nenashev added a comment -

            Fixed by JENKINS-22247 (1.566+)

            oleg_nenashev Oleg Nenashev added a comment - Fixed by JENKINS-22247 (1.566+)
            oleg_nenashev Oleg Nenashev made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 133291 ] JNJira + In-Review [ 186623 ]

            People

              Unassigned Unassigned
              taillant taillant
              Votes:
              9 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: