Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32737

Certain configurations fail to create emulator due to specifying wrong ABI tag

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      From https://stackoverflow.com/questions/35059957/cannot-create-emulator-via-jenkins-android-emulator-plugin:

      When Jenkins tries to generate my emulator, it errors out with:

      tools/android create avd -f -a -c 256M -s 1080x1920 -n hudson_de-DE_480_1080x1920_Google_Inc._Google_APIs_23_x86 -t "Google Inc.:Google APIs:23" --abi x86
      Error: Invalid --tag default for the selected target.
      

      But tools/android list targets outputs

      id: 6 or "Google Inc.:Google APIs:23"
       ...
       Tag/ABIs : google_apis/x86
      

      Back when I implemented support for ABI tags, I seem to recall it being impossible to discover the correct tag in every single case, but from this report, it should be seemingly simple enough to determine automatically choose the correct tag for this case at least.
      I can't remember what the implementation looks like, and I haven't looked at the code to see whether we're already doing something similar.

        Attachments

          Activity

            People

            Assignee:
            orrc Christopher Orr
            Reporter:
            orrc Christopher Orr
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: